summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulien Nicoulaud2019-06-25 19:40:04 +0200
committerJulien Nicoulaud2019-06-25 19:40:04 +0200
commit7ca06b653ad512a01af06c29cf52e9281ab18bb4 (patch)
treef4fb2abfb6c1ac54ddd4d429d00407e3329624f4
parent0056925252caa8927d2ff86e71e823336c5a5696 (diff)
downloadaur-7ca06b653ad512a01af06c29cf52e9281ab18bb4.tar.gz
merge changes from rga package
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD30
2 files changed, 37 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 73ecc14083af..78bd142fb646 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,28 @@
pkgbase = ripgrep-all
pkgdesc = rga: ripgrep, but also search in PDFs, E-Books, Office documents, zip, tar.gz, etc.
pkgver = 0.9.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/phiresky/ripgrep-all
+ arch = i686
arch = x86_64
+ arch = armv6h
+ arch = armv7h
license = AGPL3
+ makedepends = rust
+ makedepends = cargo
depends = ripgrep
+ depends = ffmpeg
depends = pandoc
depends = poppler
- depends = ffmpeg
- source = https://github.com/phiresky/ripgrep-all/releases/download/0.9.2/ripgrep_all-0.9.2-x86_64-unknown-linux-musl.tar.gz
- sha1sums = 59bbe4209948a7a3b74ed9fd06983c757dae747e
+ depends = tesseract
+ depends = imagemagick
+ conflicts = ripgrep-all-git
+ conflicts = ripgrep-all-bin
+ conflicts = rga
+ conflicts = rga-git
+ conflicts = rga-bin
+ source = https://github.com/phiresky/ripgrep-all/archive/0.9.2.tar.gz
+ sha512sums = ea91feae191b0dc6654572c3c7ace08ea452d3e838fdb5c3f6691a32d510f3340aa64171caf4f67db867e027317e04ffccc1aa6edc95c0ec8942d6e4d8ea0208
pkgname = ripgrep-all
diff --git a/PKGBUILD b/PKGBUILD
index bc4f5fd27588..ca7dc2972ebe 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,31 @@
# Maintainer: phiresky <phireskyde+aur@gmail.com>
+# Maintainer: Julien Nicoulaud <julien DOT nicoulaud AT gmail DOT com>
pkgname=ripgrep-all
pkgver=0.9.2
-pkgrel=1
-arch=(x86_64)
+pkgrel=2
pkgdesc="rga: ripgrep, but also search in PDFs, E-Books, Office documents, zip, tar.gz, etc."
+arch=('i686' 'x86_64' 'armv6h' 'armv7h')
url="https://github.com/phiresky/ripgrep-all"
license=('AGPL3')
-depends=('ripgrep' 'pandoc' 'poppler' 'ffmpeg')
-archivename="ripgrep_all-${pkgver}-${arch}-unknown-linux-musl"
-source=("https://github.com/phiresky/ripgrep-all/releases/download/${pkgver}/${archivename}.tar.gz")
-sha1sums=('59bbe4209948a7a3b74ed9fd06983c757dae747e')
+depends=(ripgrep ffmpeg pandoc poppler tesseract imagemagick)
+makedepends=('rust' 'cargo')
+conflicts=("${pkgname}-git" "${pkgname}-bin" "rga" "rga-git" "rga-bin")
+source=("https://github.com/phiresky/ripgrep-all/archive/${pkgver}.tar.gz")
+sha512sums=('ea91feae191b0dc6654572c3c7ace08ea452d3e838fdb5c3f6691a32d510f3340aa64171caf4f67db867e027317e04ffccc1aa6edc95c0ec8942d6e4d8ea0208')
+
+build() {
+ cd "${srcdir}/ripgrep-all-${pkgver}"
+ cargo build --release --locked
+}
+
+check() {
+ cd "${srcdir}/ripgrep-all-${pkgver}"
+ cargo test --release --locked
+}
package() {
- cd "$srcdir/$archivename"
- mkdir -p "$pkgdir/usr/bin"
- cp rga rga-preproc "$pkgdir/usr/bin"
+ cd "${srcdir}/ripgrep-all-${pkgver}"
+ install -Dm 755 "target/release/rga" "${pkgdir}/usr/bin/rga"
+ install -Dm 755 "target/release/rga-preproc" "${pkgdir}/usr/bin/rga-preproc"
}