summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortxtsd2024-12-25 23:23:27 +0530
committertxtsd2024-12-25 23:23:27 +0530
commit3b1158fb6e6a2b19d47a4ab380ff902bcbe9c28e (patch)
treec0fbdabae8d4aef5dd37d4fe41b75839183fd3c8
parent7b591d39bc69d188373fcfb41255daa7e96f29d4 (diff)
downloadaur-3b1158fb6e6a2b19d47a4ab380ff902bcbe9c28e.tar.gz
upgpkg: ripme 2.1.12-1
Upstream Release: ripme 2.1.12 Signed-off-by: txtsd <code@ihavea.quest>
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD7
-rw-r--r--ripme-2.1.9-gradle.patch10
3 files changed, 8 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98e96add993d..dad06496297c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = ripme
pkgdesc = Downloads albums in bulk
- pkgver = 2.1.11
+ pkgver = 2.1.12
pkgrel = 1
url = https://github.com/ripmeapp2/ripme
arch = any
@@ -10,7 +10,8 @@ pkgbase = ripme
makedepends = gradle
depends = java-runtime>=17
depends = bash
- source = git+https://github.com/ripmeapp2/ripme#tag=2.1.11
- sha256sums = 11b8993350dd2714ccd03f093b0b0f5ff0849267ab340b415c9356855fe1f80d
+ options = !debug
+ source = git+https://github.com/ripmeapp2/ripme#tag=2.1.12
+ sha256sums = 5a5310c938beb58b9795203782e845dca4f8c8461a8784fa881aa231916283ff
pkgname = ripme
diff --git a/PKGBUILD b/PKGBUILD
index 3e96c4ceaa1a..ee2b1430d012 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,8 @@
# Contributor: neeshy <neeshy@tfwno.gf>
pkgname=ripme
-pkgver=2.1.11
-_pkgver=2.1.10-21-c94a9543
+pkgver=2.1.12
+_pkgver=2.1.11-20-ca96ce88
pkgrel=1
pkgdesc='Downloads albums in bulk'
arch=(any)
@@ -18,8 +18,9 @@ makedepends=(
git
gradle
)
+options=(!debug)
source=("git+${url}#tag=${pkgver}")
-sha256sums=('11b8993350dd2714ccd03f093b0b0f5ff0849267ab340b415c9356855fe1f80d')
+sha256sums=('5a5310c938beb58b9795203782e845dca4f8c8461a8784fa881aa231916283ff')
build() {
cd "${pkgname}"
diff --git a/ripme-2.1.9-gradle.patch b/ripme-2.1.9-gradle.patch
deleted file mode 100644
index e63a27cc330d..000000000000
--- a/ripme-2.1.9-gradle.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/build.gradle.kts
-+++ b/build.gradle.kts
-@@ -49,6 +49,7 @@
-
- tasks.withType<Jar> {
- duplicatesStrategy = DuplicatesStrategy.INCLUDE
-+ archiveVersion.set("2.1.9")
- manifest {
- attributes["Main-Class"] = "com.rarchives.ripme.App"
- attributes["Implementation-Version"] = archiveVersion