summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2023-04-22 01:40:37 -0400
committerneeshy2023-04-22 01:44:12 -0400
commit4dcf568c9143344b2cd74d03bb1cc795e8a97f14 (patch)
tree52ef14aa7b30f1d82522ef86dff7f920c953b083
parentca9f284a3e133a40cdc6d6b89d635579cdb7db96 (diff)
downloadaur-4dcf568c9143344b2cd74d03bb1cc795e8a97f14.tar.gz
Add proper java dependencies
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 4 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3b81d8ee7b19..fdc70cd00972 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,7 +6,8 @@ pkgbase = ripme-git
arch = any
license = MIT
makedepends = git
- depends = java-runtime
+ makedepends = java-environment>=11
+ depends = java-runtime>=11
provides = ripme
conflicts = ripme
source = git+https://github.com/ripmeapp2/ripme.git
diff --git a/PKGBUILD b/PKGBUILD
index e1f7f84c47c2..5d2baaf9de1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,8 +9,8 @@ pkgdesc="Downloads albums in bulk"
arch=('any')
url="https://github.com/ripmeapp2/ripme"
license=('MIT')
-depends=('java-runtime')
-makedepends=('git')
+depends=('java-runtime>=11')
+makedepends=('git' 'java-environment>=11')
provides=('ripme')
conflicts=('ripme')
source=("git+https://github.com/ripmeapp2/ripme.git")