summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2022-11-09 04:08:09 -0500
committerneeshy2022-11-09 04:08:09 -0500
commit932440d270ca212c6123603ca60b11c571cde392 (patch)
treec31dbfde861378921177bdb6539ec586beddb3cd
parent1225d04671309594dc08ed91063cbed3c3c24af8 (diff)
downloadaur-932440d270ca212c6123603ca60b11c571cde392.tar.gz
ripme: update to fork
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e54524163362..3b81d8ee7b19 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,11 @@
pkgbase = ripme-git
pkgdesc = Downloads albums in bulk
pkgver = latest
- pkgrel = 3
- url = https://github.com/RipMeApp/ripme
+ pkgrel = 4
+ url = https://github.com/ripmeapp2/ripme
arch = any
license = MIT
makedepends = git
- makedepends = maven
- makedepends = jq
depends = java-runtime
provides = ripme
conflicts = ripme
@@ -15,4 +13,3 @@ pkgbase = ripme-git
sha256sums = SKIP
pkgname = ripme-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c486b46865f6..07dd47df9127 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,13 @@
_pkgname=ripme
pkgname="$_pkgname-git"
pkgver=latest
-pkgrel=3
+pkgrel=4
pkgdesc="Downloads albums in bulk"
arch=('any')
-url="https://github.com/RipMeApp/ripme"
+url="https://github.com/ripmeapp2/ripme"
license=('MIT')
depends=('java-runtime')
-makedepends=('git' 'maven' 'jq')
+makedepends=('git')
provides=('ripme')
conflicts=('ripme')
source=("git+https://github.com/ripmeapp2/ripme.git")
@@ -23,8 +23,8 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
- mvn clean compile assembly:single
- cat << EOF > ripme.sh
+ ./gradlew clean build
+ cat <<EOF >ripme.sh
#!/bin/sh
exec java -jar /usr/share/java/ripme.jar "\$@"
EOF
@@ -32,7 +32,7 @@ EOF
package() {
cd "$srcdir/$_pkgname"
- install -Dm644 "target/ripme-$(jq -r .latestVersion < ripme.json)-jar-with-dependencies.jar" \
+ install -Dm644 "build/libs/ripme-$(git describe --tags --exclude latest-main | sed -E 's/-g([a-f0-9])/-\1/g')-makepkg.jar" \
"$pkgdir/usr/share/java/ripme.jar"
install -Dm755 ripme.sh "$pkgdir/usr/bin/ripme"
}