summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander F. Rødseth2019-04-04 18:45:37 +0200
committerAlexander F. Rødseth2019-04-04 18:45:37 +0200
commite429bf80b0019855b47574b0a411ee9b933ea8be (patch)
tree909125b02a472c84845ed087f11565337a597483
downloadaur-e429bf80b0019855b47574b0a411ee9b933ea8be.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD37
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..08ad8500d8b4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Thu Apr 4 16:45:32 UTC 2019
+pkgbase = riscv-pk
+ pkgdesc = RISC-V proxy kernel and boot loader
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/riscv/riscv-pk
+ arch = x86_64
+ groups = risc-v
+ license = custom
+ makedepends = git
+ depends = riscv64-linux-gnu-binutils
+ depends = riscv64-linux-gnu-gcc
+ depends = riscv64-linux-gnu-libc
+ source = git+https://github.com/riscv/riscv-pk#commit=97b683ed3cbeeb059e5ad3de8f884db734447d56
+ sha256sums = SKIP
+
+pkgname = riscv-pk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cdf6543bed23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=riscv-pk
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='RISC-V proxy kernel and boot loader'
+arch=('x86_64')
+url='https://github.com/riscv/riscv-pk'
+license=('custom')
+depends=('riscv64-linux-gnu-binutils' 'riscv64-linux-gnu-gcc' 'riscv64-linux-gnu-libc')
+makedepends=('git')
+groups=(risc-v)
+source=("git+$url#commit=97b683ed3cbeeb059e5ad3de8f884db734447d56")
+sha256sums=('SKIP')
+
+build() {
+ mkdir -p build
+ cd build
+ export CFLAGS=""
+ export RISCV=/usr/riscv64-linux-gnu
+ "$srcdir/$pkgname/configure" \
+ --prefix=/usr \
+ --host=riscv64-linux-gnu \
+ --enable-shared \
+ --with-gcc \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --bindir=/usr/bin/ \
+ --with-sysroot="$RISCV"
+ make
+}
+
+package() {
+ DESTDIR="$pkgdir" PREFIX=/usr make -C build install
+}
+
+# vim: ts=2 sw=2 et: