summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJiuyang liu2019-06-25 08:50:35 +0000
committerJiuyang liu2019-06-25 08:50:35 +0000
commit2e1286cb4f3157f60184126db68aa38821d1ab8e (patch)
tree4dfe4d50e77d05eb33d4bddb96f48093ea103086
downloadaur-2e1286cb4f3157f60184126db68aa38821d1ab8e.tar.gz
init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD41
2 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8588467b94ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = riscv-pk-git
+ pkgdesc = RISC-V proxy kernel and boot loader
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/riscv/riscv-pk
+ arch = x86_64
+ groups = risc-v
+ license = custom
+ makedepends = git
+ depends = riscv64-linux-gnu-binutils
+ depends = riscv64-linux-gnu-gcc
+ depends = riscv64-linux-gnu-glibc
+ source = git+https://github.com/riscv/riscv-pk#branch=master
+ sha256sums = SKIP
+
+pkgname = riscv-pk-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97c78b9ab649
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Jiuyang Liu <liujiuyang1994@gmail.com>
+# Contributor: Alexander F. Rødseth <xyproto@archlinux.org>
+
+pkgname=riscv-pk-git
+pkgver=1
+pkgrel=1
+pkgdesc='RISC-V proxy kernel and boot loader'
+arch=(x86_64)
+url='https://github.com/riscv/riscv-pk'
+license=(custom)
+depends=(riscv64-linux-gnu-binutils riscv64-linux-gnu-gcc riscv64-linux-gnu-glibc)
+makedepends=(git)
+groups=(risc-v)
+source=("git+$url#branch=master")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ mkdir -p build
+ cd build
+ export CFLAGS=""
+ export RISCV=/usr/riscv64-linux-gnu
+ "$srcdir/$pkgname/configure" \
+ --prefix=/usr \
+ --host=riscv64-linux-gnu \
+ --enable-shared \
+ --with-gcc \
+ --with-gnu-as \
+ --with-gnu-ld \
+ --bindir=/usr/riscv64-linux-gnu/bin/ \
+ --with-sysroot="/usr/riscv64-linux-gnu"
+ make
+}
+
+package() {
+ make -C build install DESTDIR="$pkgdir" PREFIX=/usr/riscv64-linux-gnu
+}