summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMaxr19982022-08-26 16:10:15 +0200
committerMaxr19982022-08-26 16:10:15 +0200
commit4999de732bdbb90e04c9981151ce96dce84cdb32 (patch)
treeff7142ed1c795ff022d88a727f0768ef74eec578
parent30d1d1782e0217d342095e863e4c9203a2744918 (diff)
downloadaur-4999de732bdbb90e04c9981151ce96dce84cdb32.tar.gz
Update to GCC 12.2.0 and libisl 0.25
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD8
2 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a3b1b1189bb..6d299cc73e1a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = riscv64-unknown-elf-gcc
pkgdesc = The GNU Compiler Collection - cross compiler for 32bit and 64bit RISC-V bare-metal
- pkgver = 12.1.0
+ pkgver = 12.2.0
pkgrel = 2
url = http://gcc.gnu.org/
arch = i686
@@ -13,9 +13,9 @@ pkgbase = riscv64-unknown-elf-gcc
depends = libmpc
options = !emptydirs
options = !strip
- source = https://gcc.gnu.org/pub/gcc/releases/gcc-12.1.0/gcc-12.1.0.tar.xz
- source = https://libisl.sourceforge.io/isl-0.24.tar.xz
- sha256sums = 62fd634889f31c02b64af2c468f064b47ad1ca78411c45abe6ac4b5f8dd19c7b
- sha256sums = 043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad
+ source = https://gcc.gnu.org/pub/gcc/releases/gcc-12.2.0/gcc-12.2.0.tar.xz
+ source = https://libisl.sourceforge.io/isl-0.25.tar.xz
+ sha256sums = e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff
+ sha256sums = be7b210647ccadf90a2f0b000fca11a4d40546374a850db67adb32fad4b230d9
pkgname = riscv64-unknown-elf-gcc
diff --git a/PKGBUILD b/PKGBUILD
index 930fd0a9a7a0..0bfc45c8a799 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
_target=riscv64-unknown-elf
pkgname=$_target-gcc
-pkgver=12.1.0
-_islver=0.24
+pkgver=12.2.0
+_islver=0.25
pkgrel=2
#_snapshot=7-20170504
pkgdesc='The GNU Compiler Collection - cross compiler for 32bit and 64bit RISC-V bare-metal'
@@ -15,8 +15,8 @@ depends=("$_target-binutils" 'zlib' 'libmpc')
options=(!emptydirs !strip)
source=("https://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.xz"
"https://libisl.sourceforge.io/isl-$_islver.tar.xz")
-sha256sums=('62fd634889f31c02b64af2c468f064b47ad1ca78411c45abe6ac4b5f8dd19c7b'
- '043105cc544f416b48736fff8caf077fb0663a717d06b1113f16e391ac99ebad')
+sha256sums=('e549cf9cf3594a00e27b6589d4322d70e0720cdd213f39beb4181e06926230ff'
+ 'be7b210647ccadf90a2f0b000fca11a4d40546374a850db67adb32fad4b230d9')
if [[ -n "$_snapshot" ]]; then
_basedir=gcc-$_snapshot