summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Kohlstedde2018-03-31 22:16:46 +0200
committerChristian Kohlstedde2018-04-03 21:58:02 +0200
commit5c50e96424b88598da33cd50e59854faa3781763 (patch)
tree2a937f96d215c5199b03905ef8333e34719257fb
downloadaur-5c50e96424b88598da33cd50e59854faa3781763.tar.gz
A rivendell package for arch
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD86
-rw-r--r--patch-makefile.patch63
3 files changed, 185 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b856d5a595f5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = rivendell
+ pkgdesc = Open Source Radio Automation
+ pkgver = 2.19.1
+ pkgrel = 1
+ url = http://www.rivendellaudio.org/
+ arch = x86_64
+ license = GPL2
+ makedepends = patch
+ depends = curl
+ depends = libxi
+ depends = cdrtools
+ depends = id3lib
+ depends = cdparanoia
+ depends = libsndfile
+ depends = mariadb
+ depends = qt3
+ depends = libsamplerate
+ depends = soundtouch
+ depends = jack2
+ depends = alsa-lib
+ depends = flac
+ depends = faad2
+ depends = libmp4v2
+ depends = lame
+ depends = libmad
+ depends = twolame
+ depends = taglib
+ depends = libvorbis
+ backup = etc/rd.conf
+ source = http://www.rivendellaudio.org/ftpdocs/rivendell/rivendell-2.19.1.tar.gz
+ source = patch-makefile.patch
+ sha256sums = 97c957c70e3caafad4d4d6520de3d35f4ac0e90036ad1123f89c2916ecc7e23c
+ sha256sums = 5c2bfdd00353ac2b9bbbcfe3e3e7d665f77d5c9caefa255ff9356c93f455f6d0
+
+pkgname = rivendell
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..066bc2dcbc91
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,86 @@
+# Maintainer: Christian Kohlstedde <christian + arch at kohlsted.de>
+
+pkgname=rivendell
+pkgver=2.19.1
+pkgrel=1
+
+pkgdesc="Open Source Radio Automation"
+
+arch=(x86_64)
+url="http://www.rivendellaudio.org/"
+license=('GPL2')
+
+depends=(
+ 'curl'
+ 'libxi'
+ 'cdrtools'
+ 'id3lib'
+ 'cdparanoia'
+ 'libsndfile'
+ 'mariadb'
+ 'qt3'
+ 'libsamplerate'
+ 'soundtouch'
+ 'jack2'
+ 'alsa-lib'
+ 'flac'
+ 'faad2'
+ 'libmp4v2'
+ 'lame'
+ 'libmad'
+ 'twolame'
+ 'taglib'
+ 'libvorbis'
+)
+
+makedepends=(
+ 'patch'
+)
+
+backup=('etc/rd.conf')
+
+source=(
+ "http://www.rivendellaudio.org/ftpdocs/rivendell/rivendell-$pkgver.tar.gz"
+ "patch-makefile.patch"
+ )
+sha256sums=('97c957c70e3caafad4d4d6520de3d35f4ac0e90036ad1123f89c2916ecc7e23c'
+ '5c2bfdd00353ac2b9bbbcfe3e3e7d665f77d5c9caefa255ff9356c93f455f6d0')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+
+ patch -p1 < ../patch-makefile.patch
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RD_LIB_PATH="lib"
+
+ sh autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --libexecdir=/usr/lib/rivendell/web \
+ --libdir=/usr/lib \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --with-Qt-bin-dir=/usr/lib/qt3/bin \
+ --with-Qt-include-dir=/usr/include/qt3 \
+ --with-Qt-lib-dir=/usr/lib
+
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ touch building-debian
+
+ export RD_LIB_PATH="lib"
+ export DESTDIR="$pkgdir"
+ make install
+
+ mkdir -p "$pkgdir"/etc/rivendell.d
+ install -t "$pkgdir"/etc/rivendell.d -Dm755 conf/rlm_*.conf
+ install -Dm755 conf/rd.conf-sample "$pkgdir"/etc/rd.conf
+ install -Dm755 conf/rd-bin.conf "$pkgdir"/etc/httpd/conf/extra/rd-bin.conf
+}
diff --git a/patch-makefile.patch b/patch-makefile.patch
new file mode 100644
index 000000000000..234c3a088a03
--- /dev/null
+++ b/patch-makefile.patch
@@ -0,0 +1,63 @@
+diff --git a/configure.ac b/configure.ac
+index fc76d4b..338e8ef 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -99,13 +99,8 @@ fi
+ AR_GCC_TARGET()
+ AC_SUBST(VENDOR,$ar_gcc_distro)
+ AC_SUBST(ARCH,$ar_gcc_arch)
+-if test $ar_gcc_arch = x86_64 ; then
+- LIB_PATH=$PREFIX/lib64
+- AC_SUBST(RD_LIB_PATH,lib64)
+-else
+- LIB_PATH=$PREFIX/lib
+- AC_SUBST(RD_LIB_PATH,lib)
+-fi
++LIB_PATH=$PREFIX/lib
++AC_SUBST(RD_LIB_PATH,lib)
+
+ #
+ # Determine Distro
+diff --git a/pam_rd/Makefile.am b/pam_rd/Makefile.am
+index 05de5a9..79bcf0e 100644
+--- a/pam_rd/Makefile.am
++++ b/pam_rd/Makefile.am
+@@ -29,8 +29,9 @@ MOC = @QT_MOC@
+ moc_%.cpp: %.h
+ $(MOC) $< -o $@
+
++inst_prefix_dir=$(DESTDIR)
+ inst_lib_LTLIBRARIES = pam_rd.la
+-inst_libdir=/@RD_LIB_PATH@/security
++inst_libdir=$(prefix)/@RD_LIB_PATH@/security
+ dist_pam_rd_la_SOURCES = pam_rd.cpp
+ pam_rd_la_LDFLAGS = -module -shared -Xlinker -x -avoid-version -export-dynamic
+ pam_rd_la_LIBADD = @LIB_RDLIBS@ -lpam @LIBVORBIS@
+diff --git a/rdcartslots/Makefile.am b/rdcartslots/Makefile.am
+index 7f7725b..2d26452 100644
+--- a/rdcartslots/Makefile.am
++++ b/rdcartslots/Makefile.am
+@@ -37,8 +37,8 @@ uninstall-local:
+ rm -f $(DESTDIR)$(prefix)/share/rivendell/rdcartslots_*.qm
+
+ all:
+- lupdate rdcartslots.pro
+- lrelease rdcartslots.pro
++ @QT_BIN@/lupdate rdcartslots.pro
++ @QT_BIN@/lrelease rdcartslots.pro
+
+ bin_PROGRAMS = rdcartslots
+
+diff --git a/rdselect/Makefile.am b/rdselect/Makefile.am
+index 4f17037..44ebc66 100644
+--- a/rdselect/Makefile.am
++++ b/rdselect/Makefile.am
+@@ -29,7 +29,7 @@ moc_%.cpp: %.h
+ $(MOC) $< -o $@
+
+ # I18N Stuff
+-install-exec-local:
++install-exec-hook:
+ mkdir -p $(DESTDIR)$(prefix)/share/rivendell
+ cp rdselect_*.qm $(DESTDIR)$(prefix)/share/rivendell
+ chmod 4755 $(DESTDIR)$(prefix)/bin/rdselect