summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaurnimator2021-04-04 22:46:12 +1000
committerdaurnimator2021-04-04 22:46:12 +1000
commit81d6ecbc73a244590190cda4eb9a445d81d67bfa (patch)
tree5bbfc57251b13217e1842aedbc3ec237fa3f1e27
parentfb40c8b0e028dc4c7243ad80aaf473c9ab31bd4a (diff)
downloadaur-81d6ecbc73a244590190cda4eb9a445d81d67bfa.tar.gz
Add workaround for newer glibc
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD20
-rw-r--r--libc.patch20
3 files changed, 39 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 89d5a6000b33..84ae1d1866e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = river-git
pkgdesc = A dynamic tiling wayland compositor.
- pkgver = r522.c143864
+ pkgver = r577.3c1f1df
pkgrel = 1
url = https://github.com/ifreund/river
arch = x86_64
@@ -20,11 +20,13 @@ pkgbase = river-git
source = git+https://github.com/ifreund/zig-wayland.git
source = git+https://github.com/swaywm/zig-wlroots.git
source = git+https://github.com/ifreund/zig-xkbcommon.git
+ source = libc.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = d5dcd4e9e0afa149a36edc790ae5f4bd476202378d5ac7e78f954e3f9eb32938
pkgname = river-git
backup = etc/river/init
diff --git a/PKGBUILD b/PKGBUILD
index 3502c3d5e4d3..0fa5ccddbab1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daurnimator <daurnimator@archlinux.org>
pkgname="river-git"
-pkgver=r522.c143864
+pkgver=r577.3c1f1df
pkgrel=1
pkgdesc='A dynamic tiling wayland compositor.'
arch=('x86_64')
@@ -15,12 +15,14 @@ source=('git+https://github.com/ifreund/river.git'
'git+https://github.com/ifreund/zig-pixman.git'
'git+https://github.com/ifreund/zig-wayland.git'
'git+https://github.com/swaywm/zig-wlroots.git'
- 'git+https://github.com/ifreund/zig-xkbcommon.git')
+ 'git+https://github.com/ifreund/zig-xkbcommon.git'
+ 'libc.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'SKIP')
+ 'SKIP'
+ 'c3e9c81dd61a7b9e333791dd368b7bd9ec7270a0415c04a2adf578c95ed853e2')
pkgver() {
cd river
@@ -35,11 +37,18 @@ prepare() {
git config submodule.deps/zig-wlroots.url "${srcdir}/zig-wlroots"
git config submodule.deps/zig-xkbcommon.url "${srcdir}/zig-xkbcommon"
git submodule update
+
+ # Workaround https://github.com/ziglang/zig/issues/8144
+ # See https://github.com/ifreund/river/issues/232#issuecomment-794067079
+ zig libc > libc-paths
+ patch -p1 < ../libc.patch
}
build() {
cd river
zig build \
+ --search-prefix "/usr" \
+ -Dtarget=x86_64-linux-gnu \
-Drelease-safe \
-Dxwayland \
-Dman-pages
@@ -49,7 +58,10 @@ package() {
backup=('etc/river/init')
cd river
- DESTDIR="${pkgdir}" zig build --prefix "/usr" \
+ DESTDIR="${pkgdir}" zig build \
+ --prefix "/usr" \
+ --search-prefix "/usr" \
+ -Dtarget=x86_64-linux-gnu \
-Drelease-safe \
-Dxwayland \
-Dman-pages \
diff --git a/libc.patch b/libc.patch
new file mode 100644
index 000000000000..a4fdfe4a5764
--- /dev/null
+++ b/libc.patch
@@ -0,0 +1,20 @@
+diff --git a/build.zig b/build.zig
+index 33a7f8a..ef5bc86 100644
+--- a/build.zig
++++ b/build.zig
+@@ -89,6 +89,7 @@ pub fn build(b: *zbs.Builder) !void {
+ riverctl.step.dependOn(&scanner.step);
+ riverctl.addPackage(scanner.getPkg());
+ riverctl.linkLibC();
++ riverctl.setLibCFile("libc-paths");
+ riverctl.linkSystemLibrary("wayland-client");
+
+ scanner.addCSource(riverctl);
+@@ -172,6 +173,7 @@ fn addServerDeps(exe: *zbs.LibExeObjStep, scanner: *ScanProtocolsStep) void {
+ exe.step.dependOn(&scanner.step);
+
+ exe.linkLibC();
++ exe.setLibCFile("libc-paths");
+ exe.linkSystemLibrary("libevdev");
+
+ exe.addPackage(wayland);