summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2021-06-05 23:25:12 +0200
committerAndrea Feletto2021-06-05 23:25:12 +0200
commit86a5adfdae706a924320ff596d0176dc6d00f730 (patch)
tree5f9b2a086a503f8624a0ec483da40706629624f6
parent7d8e0abeaa0af6d0551c420acad7fc2a58692469 (diff)
downloadaur-86a5adfdae706a924320ff596d0176dc6d00f730.tar.gz
clone submodules according to AUR guidelines
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD18
2 files changed, 23 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2ad9498eba0d..8e3dc3c7bc92 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = river-git
pkgdesc = A dynamic tiling wayland compositor.
pkgver = r623.0e9dc08
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ifreund/river
arch = x86_64
license = GPL3
@@ -20,6 +20,14 @@ pkgbase = river-git
provides = rivertile
conflicts = river
source = git+https://github.com/ifreund/river
+ source = git+https://github.com/ifreund/zig-pixman.git
+ source = git+https://github.com/ifreund/zig-wayland.git
+ source = git+https://github.com/swaywm/zig-wlroots.git
+ source = git+https://github.com/ifreund/zig-xkbcommon.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
sha256sums = SKIP
pkgname = river-git
diff --git a/PKGBUILD b/PKGBUILD
index 4ee3dc56e8f5..b5a2725e1a7c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=river-git
_pkgname=${pkgname%-*}
pkgver=r623.0e9dc08
-pkgrel=2
+pkgrel=3
pkgdesc='A dynamic tiling wayland compositor.'
arch=('x86_64')
url='https://github.com/ifreund/river'
@@ -16,12 +16,22 @@ depends=(
)
provides=('river' 'riverctl' 'rivertile')
conflicts=('river')
-source=("git+$url")
-sha256sums=('SKIP')
+source=(
+ "git+$url"
+ 'git+https://github.com/ifreund/zig-pixman.git'
+ 'git+https://github.com/ifreund/zig-wayland.git'
+ 'git+https://github.com/swaywm/zig-wlroots.git'
+ 'git+https://github.com/ifreund/zig-xkbcommon.git'
+)
+sha256sums=('SKIP' 'SKIP' 'SKIP' 'SKIP' 'SKIP')
prepare() {
cd "$_pkgname"
- git submodule update --init
+ git submodule init
+ for dep in pixman wayland wlroots xkbcommon; do
+ git config "submodule.deps/zig-$dep.url" "$srcdir/zig-$dep"
+ done
+ git submodule update
}
pkgver() {