summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIsaac Freund2020-06-05 05:38:33 -0500
committerIsaac Freund2020-06-05 05:40:29 -0500
commita7353b6a2ec1aab4e021e6c6f9820f780a836732 (patch)
treefb40c56172011b064947e17bba9e4684ef47eeec
parent58a464efcf349454fd373d83237d985bf7f61599 (diff)
downloadaur-a7353b6a2ec1aab4e021e6c6f9820f780a836732.tar.gz
river-git: install riverctl, update license
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 9 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 969f24307501..775b83f370ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = river-git
- pkgdesc = A dyanmic wayland compositor.
- pkgver = r171.7988a2e
- pkgrel = 2
+ pkgdesc = A dynamic tiling wayland compositor.
+ pkgver = r264.59d0fb7
+ pkgrel = 1
url = https://github.com/ifreund/river
arch = any
- license = MIT
+ license = GPL3
makedepends = git
makedepends = wayland-protocols
depends = zig
diff --git a/PKGBUILD b/PKGBUILD
index 39babc2a47a5..f193feb8daa1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,11 @@
_pkgname='river'
pkgname="${_pkgname}-git"
-pkgver=r171.7988a2e
-pkgrel=2
-pkgdesc='A dyanmic wayland compositor.'
+pkgver=r264.59d0fb7
+pkgrel=1
+pkgdesc='A dynamic tiling wayland compositor.'
arch=('any')
url="https://github.com/ifreund/${_pkgname}"
-license=('MIT')
+license=('GPL3')
depends=('zig' 'wlroots')
makedepends=('git' 'wayland-protocols')
provides=('river')
@@ -23,14 +23,7 @@ build() {
zig build -Drelease-safe
}
-check() {
- cd "${_pkgname}"
- zig build test -Drelease-safe
-}
-
package() {
cd "${_pkgname}"
- zig build install -Drelease-safe --prefix .
- install -Dm 755 bin/river -t "${pkgdir}/usr/bin/"
- install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${_pkgname}/"
+ zig build -Drelease-safe --prefix "${pkgdir}/usr" install
}