summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-10-25 21:40:48 +0000
committerxiota2024-10-25 21:40:48 +0000
commitbbc2c63cbdd0da612c72279f90f71a896e669367 (patch)
tree74bb3a4a6e9c8747000bee22da30c081c7ef33b4
parente7cc3148bbf0399eaea598d61bde0ee7e37ce827 (diff)
downloadaur-bbc2c63cbdd0da612c72279f90f71a896e669367.tar.gz
wip
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 5 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f1100e8c08c7..0785fefa8aa0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,16 +20,7 @@ pkgbase = river-git
optdepends = polkit: access seat through systemd-logind
provides = river
conflicts = river
- options = !strip
source = git+https://github.com/riverwm/river.git
- source = git+https://github.com/ifreund/zig-pixman.git
- source = git+https://github.com/ifreund/zig-wayland.git
- source = git+https://github.com/swaywm/zig-wlroots.git
- source = git+https://github.com/ifreund/zig-xkbcommon.git
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
- sha256sums = SKIP
sha256sums = SKIP
pkgname = river-git
diff --git a/PKGBUILD b/PKGBUILD
index a777e6502d8c..24c8f74bee58 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -48,31 +48,15 @@ optdepends=(
provides=("$_pkgname")
conflicts=("$_pkgname")
-options=('!strip')
-
_pkgsrc="$_pkgname"
-source=(
- 'git+https://github.com/riverwm/river.git'
- 'git+https://github.com/ifreund/zig-pixman.git'
- 'git+https://github.com/ifreund/zig-wayland.git'
- 'git+https://github.com/swaywm/zig-wlroots.git'
- 'git+https://github.com/ifreund/zig-xkbcommon.git'
-)
-sha256sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
-)
+source=('git+https://github.com/riverwm/river.git')
+sha256sums=('SKIP')
prepare() {
- cd "$_pkgsrc"
- git submodule init
- for dep in pixman wayland wlroots xkbcommon; do
- git config "submodule.deps/zig-$dep.url" "$srcdir/zig-$dep"
+ # PACKAGING.md -> build.zig.zon
+ for i in $(grep '\.url' "$_pkgsrc"/build.zig.zon | sed -E 's&^.* = "(\S+)".*$&\1&'); do
+ zig fetch --global-cache-dir ./zig-global-cache "$i"
done
- git -c protocol.file.allow=always submodule update
}
pkgver() {