summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2024-03-25 02:24:10 +0000
committerxiota2024-03-25 02:24:10 +0000
commitc658c62b9eb4ea3c62891c51669ac14669fe487a (patch)
treeea516937fb8dc69ea9b2c644059bc9505b25793d
parenta98dbd37505e55958ca88d9ba8e890d64508ea5d (diff)
downloadaur-c658c62b9eb4ea3c62891c51669ac14669fe487a.tar.gz
0.2.6.r285.g12de175
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD35
2 files changed, 22 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e594cd910561..5f7788a8b2fb 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = river-git
pkgdesc = Dynamic tiling wayland compositor
- pkgver = 0.3.0dev.r141.g5da4769
+ pkgver = 0.2.6.r285.g12de175
pkgrel = 1
- url = https://github.com/riverwm/river
+ url = https://codeberg.org/river/river
arch = x86_64
- license = GPL3
+ license = GPL-3.0-only
makedepends = git
makedepends = scdoc
makedepends = zig
diff --git a/PKGBUILD b/PKGBUILD
index 9a779f15a56b..464df1d74d18 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,17 @@
# Contributor: Andrea Feletto <andrea@andreafeletto.com>
# Contributor: Daurnimator <daurnimator@archlinux.org>
+## useful links
+# https://codeberg.org/river/river
+# https://github.com/riverwm/river
+
_pkgname="river"
pkgname="$_pkgname-git"
-pkgver=0.3.0dev.r141.g5da4769
+pkgver=0.2.6.r285.g12de175
pkgrel=1
pkgdesc='Dynamic tiling wayland compositor'
-url='https://github.com/riverwm/river'
-license=('GPL3')
+url='https://codeberg.org/river/river'
+license=('GPL-3.0-only')
arch=('x86_64')
depends=(
@@ -37,7 +41,7 @@ options=('!strip')
_pkgsrc="$_pkgname"
source=(
- "git+$url.git"
+ "git+https://github.com/riverwm/river.git"
'git+https://github.com/ifreund/zig-pixman.git'
'git+https://github.com/ifreund/zig-wayland.git'
'git+https://github.com/swaywm/zig-wlroots.git'
@@ -61,14 +65,13 @@ prepare() {
}
pkgver() {
- local _version _commit_count _commit_hash
-
cd "$_pkgsrc"
- _version=$(sed -n 's/-//;s/^const version = "\(.*\)";/\1/p' build.zig)
- _commit_count=$(git describe --long | cut -d- -f2)
- _commit_hash=$(git describe --long | cut -d- -f3)
+ local _tag=$(git tag | sort -rV | head -1)
+ local _version"=${_tag#v}"
+ local _revision=$(git rev-list --count --cherry-pick "$_tag"...HEAD)
+ local _hash=$(git rev-parse --short=7 HEAD)
- printf '%s.r%s.%s' "$_version" "$_commit_count" "$_commit_hash"
+ printf '%s.r%s.g%s' "${_version:?}" "${_revision:?}" "${_hash:?}"
}
package() {
@@ -79,12 +82,12 @@ package() {
-Dxwayland
)
- DESTDIR="${pkgdir:?}" zig build "${_zig_options[@]}"
+ DESTDIR="$pkgdir" zig build "${_zig_options[@]}"
- install -Dm644 LICENSE -t "${pkgdir:?}/usr/share/licenses/$pkgname/"
- install -Dm644 README.md -t "${pkgdir:?}/usr/share/doc/$pkgname/"
- install -Dm644 contrib/river.desktop -t "${pkgdir:?}/usr/share/wayland-sessions/"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm644 contrib/river.desktop -t "$pkgdir/usr/share/wayland-sessions/"
- install -d "${pkgdir:?}/usr/share/$_pkgname"
- cp --reflink=auto -fr example "${pkgdir:?}/usr/share/$_pkgname/"
+ install -d "$pkgdir/usr/share/$_pkgname"
+ cp --reflink=auto -fr example "$pkgdir/usr/share/$_pkgname/"
}