summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordaurnimator2020-12-31 12:32:50 +1100
committerdaurnimator2020-12-31 12:32:50 +1100
commitfb40c8b0e028dc4c7243ad80aaf473c9ab31bd4a (patch)
tree98c520beb4bcdccc3278c89f59da3486a3c1e842
parent96bac818b1d8a53308741ad4651531bd2430a5bf (diff)
downloadaur-fb40c8b0e028dc4c7243ad80aaf473c9ab31bd4a.tar.gz
Update to latest master
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD32
2 files changed, 38 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd175221f0cb..89d5a6000b33 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = river-git
pkgdesc = A dynamic tiling wayland compositor.
- pkgver = r476.2b24e55
+ pkgver = r522.c143864
pkgrel = 1
url = https://github.com/ifreund/river
arch = x86_64
@@ -9,13 +9,23 @@ pkgbase = river-git
makedepends = scdoc
makedepends = wayland-protocols
makedepends = zig
+ depends = libevdev
+ depends = libxkbcommon
+ depends = pixman
depends = wlroots
provides = river
conflicts = river
source = git+https://github.com/ifreund/river.git
+ source = git+https://github.com/ifreund/zig-pixman.git
source = git+https://github.com/ifreund/zig-wayland.git
- md5sums = SKIP
- md5sums = SKIP
+ source = git+https://github.com/swaywm/zig-wlroots.git
+ source = git+https://github.com/ifreund/zig-xkbcommon.git
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
pkgname = river-git
+ backup = etc/river/init
diff --git a/PKGBUILD b/PKGBUILD
index 44c24e37cac3..3502c3d5e4d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,26 @@
# Maintainer: Daurnimator <daurnimator@archlinux.org>
pkgname="river-git"
-pkgver=r476.2b24e55
+pkgver=r522.c143864
pkgrel=1
pkgdesc='A dynamic tiling wayland compositor.'
arch=('x86_64')
url='https://github.com/ifreund/river'
license=('GPL3')
-depends=('wlroots')
+depends=('libevdev' 'libxkbcommon' 'pixman' 'wlroots')
makedepends=('git' 'scdoc' 'wayland-protocols' 'zig')
provides=('river')
conflicts=('river')
source=('git+https://github.com/ifreund/river.git'
- 'git+https://github.com/ifreund/zig-wayland.git')
-md5sums=('SKIP'
- 'SKIP')
+ 'git+https://github.com/ifreund/zig-pixman.git'
+ 'git+https://github.com/ifreund/zig-wayland.git'
+ 'git+https://github.com/swaywm/zig-wlroots.git'
+ 'git+https://github.com/ifreund/zig-xkbcommon.git')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP')
pkgver() {
cd river
@@ -24,16 +30,28 @@ pkgver() {
prepare() {
cd river
git submodule init
+ git config submodule.deps/zig-pixman.url "${srcdir}/zig-pixman"
git config submodule.deps/zig-wayland.url "${srcdir}/zig-wayland"
+ git config submodule.deps/zig-wlroots.url "${srcdir}/zig-wlroots"
+ git config submodule.deps/zig-xkbcommon.url "${srcdir}/zig-xkbcommon"
git submodule update
}
build() {
cd river
- zig build -Drelease-safe -Dxwayland
+ zig build \
+ -Drelease-safe \
+ -Dxwayland \
+ -Dman-pages
}
package() {
+ backup=('etc/river/init')
+
cd river
- zig build -Drelease-safe -Dxwayland --prefix "${pkgdir}/usr" install
+ DESTDIR="${pkgdir}" zig build --prefix "/usr" \
+ -Drelease-safe \
+ -Dxwayland \
+ -Dman-pages \
+ install
}