summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2019-02-17 14:23:47 +0100
committerFrank Siegert2019-02-17 14:23:47 +0100
commit0838870addc508c3ed34ac9e8f0e5e0cc1d84f7f (patch)
tree2bf0b7af5e3f15675151f89a37740755c273cdec
parentfd1e2d9af77bcb1c1d0cdecba8c374746a9533ad (diff)
downloadaur-0838870addc508c3ed34ac9e8f0e5e0cc1d84f7f.tar.gz
Update to 2.7.0-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 702563eb94f7..305fa3f62908 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Mon Dec 10 22:41:14 UTC 2018
+# Sun Feb 17 13:23:47 UTC 2019
pkgbase = rivet
pkgdesc = A particle physics package for data analysis and validation of Monte Carlo event generators
- pkgver = 2.6.2
+ pkgver = 2.7.0
pkgrel = 1
url = http://rivet.hepforge.org
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = rivet
license = GPL3
makedepends = cython
depends = python
- depends = yoda>=1.7.1
+ depends = yoda>=1.7.4
depends = fastjet
depends = gsl
depends = hepmc
@@ -18,8 +18,8 @@ pkgbase = rivet
optdepends = ghostscript: PDF plot output
optdepends = imagemagick: PNG plot output
optdepends = python2: For Python2 module in addition to Python3
- source = http://www.hepforge.org/archive/rivet/Rivet-2.6.2.tar.gz
- md5sums = 2f3c5ef45bb858b2fc14e91a3d0cb25a
+ source = http://www.hepforge.org/archive/rivet/Rivet-2.7.0.tar.gz
+ md5sums = dfb7378e05cab9056923db3698030579
pkgname = rivet
diff --git a/PKGBUILD b/PKGBUILD
index e013137b5c18..adcb4b30a76b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,22 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=rivet
-pkgver=2.6.2
+pkgver=2.7.0
pkgrel=1
pkgdesc="A particle physics package for data analysis and validation of Monte Carlo event generators"
arch=('x86_64' 'i686')
url="http://rivet.hepforge.org"
license=('GPL3')
-depends=('python' 'yoda>=1.7.1' 'fastjet' 'gsl' 'hepmc')
+depends=('python' 'yoda>=1.7.4' 'fastjet' 'gsl' 'hepmc')
optdepends=('texlive-core: Plotting functionality'
'ghostscript: PDF plot output'
'imagemagick: PNG plot output'
'python2: For Python2 module in addition to Python3')
makedepends=('cython')
source=(http://www.hepforge.org/archive/rivet/Rivet-$pkgver.tar.gz)
-md5sums=('2f3c5ef45bb858b2fc14e91a3d0cb25a')
+md5sums=('dfb7378e05cab9056923db3698030579')
build() {
cd "$srcdir/Rivet-$pkgver"
- ## need to rebuild Python extension code with up-to-date Cython for Python 3.7
- ## will eventually be fixed upstream
- touch pyext/rivet/*.pyx
./configure --prefix=/usr
make
}