summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2019-05-23 13:46:01 +0200
committerFrank Siegert2019-05-23 13:46:01 +0200
commit0a0cb3e0684ca979eadc11e8b064852ac093cfed (patch)
treedf6148fd4e0ab12eb733103803ed044151b7f3c5
parent9ced292ef5174856c549e0781bde78b5e431c7e7 (diff)
downloadaur-0a0cb3e0684ca979eadc11e8b064852ac093cfed.tar.gz
Update to 2.7.2-3
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--rivet-python3.patch20
3 files changed, 32 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3afc05805e3a..4d3ff40b65e0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rivet
pkgdesc = A particle physics package for data analysis and validation of Monte Carlo event generators
- pkgver = 2.7.1
- pkgrel = 1
+ pkgver = 2.7.2
+ pkgrel = 3
url = http://rivet.hepforge.org
arch = x86_64
arch = i686
@@ -16,8 +16,10 @@ pkgbase = rivet
optdepends = ghostscript: PDF plot output
optdepends = imagemagick: PNG plot output
optdepends = python2: For Python2 module in addition to Python3
- source = http://www.hepforge.org/archive/rivet/Rivet-2.7.1.tar.gz
- md5sums = 761cfe8b6500f89131b293cf6d31a3b4
+ source = http://www.hepforge.org/archive/rivet/Rivet-2.7.2.tar.gz
+ source = rivet-python3.patch
+ md5sums = 9b4061fbb79791045ffdff6b16c8272a
+ md5sums = e9476790ce0f6709713561583a8fbc10
pkgname = rivet
diff --git a/PKGBUILD b/PKGBUILD
index dc6d62dd981b..ebc157d47aa6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
pkgname=rivet
-pkgver=2.7.1
-pkgrel=1
+pkgver=2.7.2
+pkgrel=3
pkgdesc="A particle physics package for data analysis and validation of Monte Carlo event generators"
arch=('x86_64' 'i686')
url="http://rivet.hepforge.org"
@@ -12,11 +12,13 @@ optdepends=('texlive-core: Plotting functionality'
'imagemagick: PNG plot output'
'python2: For Python2 module in addition to Python3')
makedepends=('cython')
-source=(http://www.hepforge.org/archive/rivet/Rivet-$pkgver.tar.gz)
-md5sums=('761cfe8b6500f89131b293cf6d31a3b4')
+source=(http://www.hepforge.org/archive/rivet/Rivet-$pkgver.tar.gz rivet-python3.patch)
+md5sums=('9b4061fbb79791045ffdff6b16c8272a'
+ 'e9476790ce0f6709713561583a8fbc10')
build() {
cd "$srcdir/Rivet-$pkgver"
+ patch -p1 < $srcdir/rivet-python3.patch
./configure --prefix=/usr
make
}
diff --git a/rivet-python3.patch b/rivet-python3.patch
new file mode 100644
index 000000000000..272c72eda1c7
--- /dev/null
+++ b/rivet-python3.patch
@@ -0,0 +1,20 @@
+--- Rivet-2.7.2/bin/rivet 2019-05-11 16:41:04.000000000 +0200
++++ /usr/bin/rivet 2019-05-23 11:27:24.561229428 +0200
+@@ -99,7 +99,7 @@
+ extragroup.add_argument("-d", "--dump", "--histo-interval", dest="DUMP_PERIOD", type=int,
+ default=1000, metavar="NUM",
+ help="specify the number of events between histogram file updates, "
+- "default = %default. Set to 0 to only write out at the end of the run. "
++ "default = %(default)s. Set to 0 to only write out at the end of the run. "
+ "Note that intermediate histograms will be those from the analyze step "
+ "only, except for analyses explicitly declared Reentrant for which the "
+ "finalize function is executed first.")
+@@ -367,7 +367,7 @@
+ import tempfile, subprocess
+ tffd, tfpath = tempfile.mkstemp(prefix="rivet-show.")
+ msgsum = u"\n\n".join(msgs)
+- if type(u'') is not str:
++ if type(u'') is str:
+ msgsum = msgsum.encode('utf-8')
+ os.write(tffd, msgsum)
+ if sys.stdout.isatty():