summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrank Siegert2019-11-19 09:20:10 +0100
committerFrank Siegert2019-11-19 09:20:10 +0100
commitbc9306e469c4b63fc9efb87acca23c20961e0c7e (patch)
tree422d54361a85da99de3909b508675161a8161898
downloadaur-bc9306e469c4b63fc9efb87acca23c20961e0c7e.tar.gz
Rivet hg -> git transition
This replaces the package rivet-hg, as Rivet development has shifted from hg to git repositories
-rw-r--r--.SRCINFO27
-rw-r--r--PKGBUILD45
2 files changed, 72 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a534b5e648f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = rivet-git
+ pkgdesc = A particle physics package for data analysis and validation of Monte Carlo event generators -- latest build from git repo
+ pkgver = 3.0.1.r207.g2818879d1
+ pkgrel = 1
+ url = http://rivet.hepforge.org
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ makedepends = cython
+ depends = python
+ depends = yoda
+ depends = fastjet
+ depends = gsl
+ depends = hepmc
+ depends = fastjet-contrib
+ optdepends = texlive-core: Plotting functionality
+ optdepends = ghostscript: PDF plot output
+ optdepends = imagemagick: PNG plot output
+ optdepends = python2: For Python2 module in addition to Python3
+ provides = rivet
+ conflicts = rivet
+ replaces = rivet-hg
+ source = git+https://gitlab.com/hepcedar/rivet.git
+ md5sums = SKIP
+
+pkgname = rivet-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4ea08226b04a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: Frank Siegert <frank.siegert@googlemail.com>
+pkgname=rivet-git
+pkgver=3.0.1.r207.g2818879d1
+pkgrel=1
+pkgdesc="A particle physics package for data analysis and validation of Monte Carlo event generators -- latest build from git repo"
+arch=('x86_64' 'i686')
+url="http://rivet.hepforge.org"
+license=('GPL3')
+conflicts=('rivet')
+provides=('rivet')
+replaces=('rivet-hg')
+depends=('python' 'yoda' 'fastjet' 'gsl' 'hepmc' 'fastjet-contrib')
+optdepends=('texlive-core: Plotting functionality'
+ 'ghostscript: PDF plot output'
+ 'imagemagick: PNG plot output'
+ 'python2: For Python2 module in addition to Python3')
+makedepends=('cython')
+source=('git+https://gitlab.com/hepcedar/rivet.git')
+md5sums=('SKIP')
+
+build() {
+ cd "$srcdir/rivet"
+ autoreconf -i
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/rivet"
+ make DESTDIR="$pkgdir/" install
+
+ # If python2 is present, also build a library for it
+ if [ -x /usr/bin/python2 ]; then
+ PYTHON=/usr/bin/python2 ./configure --prefix=/usr
+ make DESTDIR="$pkgdir/" install
+ fi
+
+ mkdir -p $pkgdir/etc/bash_completion.d
+ mv $pkgdir/usr/share/Rivet/rivet-completion $pkgdir/etc/bash_completion.d
+}
+
+pkgver() {
+ cd "$srcdir/rivet"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g' | sed 's/rivet\.//g'
+}