summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Roest2022-02-24 14:25:50 +0100
committerVictor Roest2022-02-24 14:25:50 +0100
commitd0cd6c9c293dd9b3b013a37734ea0847cc6f0c34 (patch)
treeeacd1c154b51d3f00f7d73374bd5eaa458babd89
parent371c389e7704104bd7aa6b4ffc9a1f6a37cb70d2 (diff)
downloadaur-d0cd6c9c293dd9b3b013a37734ea0847cc6f0c34.tar.gz
1.3.7
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD54
2 files changed, 29 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 25897a209683..deb7e19b4bd0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = rke
pkgdesc = An extremely simple, lightning fast Kubernetes installer that works everywhere.
- pkgver = 1.3.3
+ pkgver = 1.3.7
pkgrel = 1
url = https://github.com/rancher/rke
arch = x86_64
license = Apache
makedepends = git
makedepends = go>=1.11
- source = rke-1.3.3::git+https://github.com/rancher/rke#tag=v1.3.3
+ source = rke-1.3.7::git+https://github.com/rancher/rke#tag=v1.3.7
source = build.patch
source = ci.patch
source = version.patch
diff --git a/PKGBUILD b/PKGBUILD
index 2e0d31b881be..0e43fbc59bee 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Michael William Le Nguyen <michael at mail dot ttp dot codes>
# Co-Maintainer: Victor Roest <victor at xirion dot net>
pkgname=rke
-pkgver=1.3.3
+pkgver=1.3.7
pkgrel=1
pkgdesc="An extremely simple, lightning fast Kubernetes installer that works everywhere."
arch=('x86_64')
@@ -9,15 +9,15 @@ url="https://github.com/rancher/rke"
license=('Apache')
makedepends=(
- "git"
- # Cannot be built with go-pie due to rke's build flags.
- "go>=1.11"
+ "git"
+ # Cannot be built with go-pie due to rke's build flags.
+ "go>=1.11"
)
source=(
- "rke-${pkgver}::git+https://github.com/rancher/rke#tag=v${pkgver}"
- "build.patch"
- "ci.patch"
- "version.patch"
+ "rke-${pkgver}::git+https://github.com/rancher/rke#tag=v${pkgver}"
+ "build.patch"
+ "ci.patch"
+ "version.patch"
"validate.patch"
)
sha512sums=('SKIP'
@@ -27,29 +27,29 @@ sha512sums=('SKIP'
'2707143f518c076b25ab46ae9e4bb6eb2959e80d594a2c671faf8797aded21615f2881a1462a1e136544caed7051b0c2c4d10d8c910d90359468aa905fd4ba0b')
prepare () {
- cd "${pkgname}-${pkgver}"
- patch --forward --strip=1 --input="${srcdir}/build.patch"
- patch --forward --strip=1 --input="${srcdir}/ci.patch"
- patch --forward --strip=1 --input="${srcdir}/version.patch"
- patch --forward --strip=1 --input="${srcdir}/validate.patch"
+ cd "${pkgname}-${pkgver}"
+ patch --forward --strip=1 --input="${srcdir}/build.patch"
+ patch --forward --strip=1 --input="${srcdir}/ci.patch"
+ patch --forward --strip=1 --input="${srcdir}/version.patch"
+ patch --forward --strip=1 --input="${srcdir}/validate.patch"
}
build () {
- export GOPATH="${srcdir}/go"
- cd "${pkgname}-${pkgver}"
- ./scripts/entry build
+ export GOPATH="${srcdir}/go"
+ cd "${pkgname}-${pkgver}"
+ ./scripts/entry build
}
check () {
- export GOPATH="${srcdir}/go"
- export PATH="$PATH:${srcdir}/go/bin"
- go get -u golang.org/x/lint/golint
- cd "${pkgname}-${pkgver}"
- ./scripts/entry test
- ./scripts/entry validate
- # Integration tests not run due to requiring a ton of kernel modules just to test locally.
+ export GOPATH="${srcdir}/go"
+ export PATH="$PATH:${srcdir}/go/bin"
+ go get -u golang.org/x/lint/golint
+ cd "${pkgname}-${pkgver}"
+ ./scripts/entry test
+ ./scripts/entry validate
+ # Integration tests not run due to requiring a ton of kernel modules just to test locally.
}
package() {
- export GOPATH="${srcdir}/go"
- # *sigh*: https://github.com/golang/go/issues/27455
- go clean -modcache
- install -D -m755 "${srcdir}/${pkgname}-${pkgver}/bin/rke" "${pkgdir}/usr/bin/${pkgname}"
+ export GOPATH="${srcdir}/go"
+ # *sigh*: https://github.com/golang/go/issues/27455
+ go clean -modcache
+ install -D -m755 "${srcdir}/${pkgname}-${pkgver}/bin/rke" "${pkgdir}/usr/bin/${pkgname}"
}