summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVictor Roest2020-06-12 13:24:28 +0200
committerVictor Roest2020-06-12 13:24:28 +0200
commiteabf08686a0bac29a1de9d60c3a3d7dd63d8a2e9 (patch)
treece37202f5669e4bc443822d04edce986a30b425e
parent92b88e0a45d73882015def3540a240809d1e4d38 (diff)
downloadaur-eabf08686a0bac29a1de9d60c3a3d7dd63d8a2e9.tar.gz
Added ARM support. Provided by zer0def
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 15 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b15f05c912e9..9394ebbc2fb7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,13 @@
pkgbase = rke-bin
pkgdesc = Rancher Kubernetes Engine, an extremely simple, lightning fast Kubernetes installer that works everywhere.
pkgver = v1.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/rancher/rke
arch = x86_64
+ arch = aarch64
+ arch = arm
+ arch = armv6h
+ arch = armv7h
license = Apache
provides = rke
source = rke-v1.1.2::https://github.com/rancher/rke/releases/download/v1.1.2/rke_linux-amd64
diff --git a/PKGBUILD b/PKGBUILD
index ae0be489f3fe..d056e37732e7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,21 @@
pkgname=rke-bin
pkgver=v1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc='Rancher Kubernetes Engine, an extremely simple, lightning fast Kubernetes installer that works everywhere.'
-arch=('x86_64')
+arch=('x86_64' 'aarch64' 'arm' 'armv6h' 'armv7h')
url='https://github.com/rancher/rke'
license=('Apache')
provides=('rke')
_rke_file=rke-$pkgver
-source=($_rke_file::"https://github.com/rancher/rke/releases/download/${pkgver}/rke_linux-amd64")
-sha256sums=('4037709ae20aab7d21ae0bac4ce2c14731f2e0df8f24adbd14b96355eae81231')
+
+case "${CARCH}" in
+ x86_64) _CARCH=amd64 && sha256sums=('4037709ae20aab7d21ae0bac4ce2c14731f2e0df8f24adbd14b96355eae81231');;
+ aarch64) _CARCH=arm64 && sha256sums=('7ec118b62d9d7c10ea649fa067aa0be316d2e499ce68f120655b4c07d6e8580b');;
+ arm*) _CARCH=arm && sha256sums=('01a3f0d8d915b6e722201ce2167f8009da7cc91e5542d3077a5ea672790a24ff');;
+esac
+
+source=($_rke_file::"https://github.com/rancher/rke/releases/download/${pkgver}/rke_linux-${_CARCH}")
package() {
install -Dm 755 "$srcdir/$_rke_file" "${pkgdir}/usr/bin/rke"