summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-02-02 11:41:14 +0100
committeraksr2016-02-02 11:41:14 +0100
commitd3fedfc3213ca36a1ae7ea546ffd51e9ac7635c7 (patch)
tree0bd3364e888c8751ef94fe6554a873b36cd8ef7c
downloadaur-d3fedfc3213ca36a1ae7ea546ffd51e9ac7635c7.tar.gz
Start.
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD45
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad1c8333cee1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Tue Feb 2 10:41:14 UTC 2016
+pkgbase = rlcmp-git
+ pkgdesc = Recursive file compare tool
+ pkgver = 1.0.0.r6.g53a0abf
+ pkgrel = 1
+ url = https://github.com/n-t-roff/rlcmp
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = libavlbst-git
+ provides = rlcmp
+ conflicts = rlcmp
+ source = rlcmp-git::git+https://github.com/n-t-roff/rlcmp.git
+ md5sums = SKIP
+
+pkgname = rlcmp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..260df765accb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,45 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=rlcmp-git
+pkgver=1.0.0.r6.g53a0abf
+pkgrel=1
+epoch=
+pkgdesc="Recursive file compare tool"
+arch=('i686' 'x86_64')
+url="https://github.com/n-t-roff/rlcmp"
+license=('GPL')
+groups=()
+depends=('libavlbst-git')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=('rlcmp')
+conflicts=('rlcmp')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+source=("$pkgname::git+https://github.com/n-t-roff/rlcmp.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ ./configure --prefix=/usr
+ make INCDIR=/usr/include LIBDIR=/usr/lib
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ make BINDIR=$pkgdir/usr/bin \
+ MANDIR=$pkgdir/usr/share/man \
+ INCDIR=$pkgdir/usr//include \
+ LIBDIR=$pkgdir/usr/lib install
+
+}
+