summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRobbert van der Helm2017-07-10 00:29:08 +0200
committerRobbert van der Helm2017-07-10 00:29:08 +0200
commitda978772be790cbcbe0041def9f090a032bc08fe (patch)
tree0bfab891dbe8b62bb6f0b1d928daecc44a036813
downloadaur-da978772be790cbcbe0041def9f090a032bc08fe.tar.gz
Create package for rlipython 0.1.2
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD20
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0152ee076b26
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rlipython
+ pkgdesc = Readline Interface for IPython 3.4+
+ pkgver = 0.1.2
+ pkgrel = 1
+ url = https://github.com/ipython/rlipython
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = ipython>=6.0
+ source = git+https://github.com/ipython/rlipython.git#commit=e218435e396a5798e001f732afa5b5e5fdc93ce0
+ md5sums = SKIP
+
+pkgname = rlipython
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..05c6d4d4c97b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!.gitignore
+!.SRCINFO
+!PKGBUILD
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e32cd55b5c40
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Robbert van der Helm <mail@robbertvanderhelm.nl>
+pkgname=rlipython
+pkgver=0.1.2
+pkgrel=1
+epoch=
+pkgdesc="Readline Interface for IPython 3.4+"
+arch=('any')
+url="https://github.com/ipython/rlipython"
+license=('BSD')
+depends=('ipython>=6.0')
+makedepends=('python-setuptools')
+source=("git+https://github.com/ipython/rlipython.git#commit=e218435e396a5798e001f732afa5b5e5fdc93ce0")
+md5sums=('SKIP')
+
+package() {
+ cd "$pkgname"
+ python setupegg.py install -O1 --root="$pkgdir"
+
+ install -D -m644 LICENSE.rst "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}