summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorИлья Федин2019-12-05 08:42:45 +0400
committerИлья Федин2019-12-05 08:42:45 +0400
commit429de44fc1809f5636e946cf5aa4cfc4cb441bc5 (patch)
tree06da9ef12271d645ee1acf6b2e948999a4816031
downloadaur-429de44fc1809f5636e946cf5aa4cfc4cb441bc5.tar.gz
Initialize rlottie-tdesktop package
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..50f58bd335c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = rlottie-tdesktop
+ pkgdesc = A platform independent standalone library that plays Lottie Animation (tdesktop fork)
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/desktop-app/rlottie
+ arch = x86_64
+ license = LGPL2.1
+ makedepends = meson
+ depends = gcc-libs
+ provides = rlottie
+ conflicts = rlottie
+ source = https://github.com/desktop-app/rlottie/archive/c490c7a098b9b3cbc3195b00e90d6fc3989e2ba2.zip
+ sha512sums = 7da1a9bb6b02de85cba24bba58d81fb0f8c54eeace24454ac7337c8be63a9314a7996adbd841213c8c67162984253544fcc87059bcf0277c2a911cf182747aae
+
+pkgname = rlottie-tdesktop
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..18973c7dd1de
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.zip
+rlottie-tdesktop-*.tar*
+pkg/
+src/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b2c41de5e5fb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Ilya Fedin <ilya-fedin@outlook.com>
+
+pkgname=rlottie-tdesktop
+_pkgname=rlottie
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="A platform independent standalone library that plays Lottie Animation (tdesktop fork)"
+arch=(x86_64)
+url="https://github.com/desktop-app/rlottie"
+license=(LGPL2.1)
+depends=(gcc-libs)
+makedepends=(meson)
+conflicts=(rlottie)
+provides=(rlottie)
+_commit="c490c7a098b9b3cbc3195b00e90d6fc3989e2ba2"
+source=("https://github.com/desktop-app/rlottie/archive/${_commit}.zip")
+sha512sums=('7da1a9bb6b02de85cba24bba58d81fb0f8c54eeace24454ac7337c8be63a9314a7996adbd841213c8c67162984253544fcc87059bcf0277c2a911cf182747aae')
+
+build() {
+ cd "$srcdir/${_pkgname}-${_commit}"
+ arch-meson build
+ ninja -C build
+}
+
+package() {
+ cd "$srcdir/${_pkgname}-${_commit}"
+ DESTDIR="$pkgdir" meson install -C build
+}