summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2019-08-01 04:23:09 -0400
committerneeshy2020-04-02 13:41:56 -0400
commita87466abe6b9d2eac65ceb637983d183ac0d5ea2 (patch)
tree213900ea8af54ffc0fd126751adf1fed5aad5e6f
parent2c77c577ad9de77f97e5213f8f48e9e9ed129533 (diff)
downloadaur-a87466abe6b9d2eac65ceb637983d183ac0d5ea2.tar.gz
Add freetype patch and proper dependencies
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--freetype.patch13
3 files changed, 26 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c887892ba901..6c67918ba7a9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,6 +6,7 @@ pkgbase = rlvm-git
arch = i686
arch = x86_64
license = GPL
+ makedepends = git
makedepends = scons
makedepends = boost
depends = boost-libs>=1.46
@@ -15,12 +16,15 @@ pkgbase = rlvm-git
depends = sdl_image
depends = sdl_ttf
depends = guichan
+ depends = gtk2
provides = rlvm
conflicts = rlvm
source = git+https://github.com/eglaysher/rlvm.git
source = detect_guichan.patch
+ source = freetype.patch
md5sums = SKIP
md5sums = caf806e9f037ba95a747a0aefde7fd9d
+ md5sums = 60d11c6a9b259eda3ee69c6a6ddaffac
pkgname = rlvm-git
diff --git a/PKGBUILD b/PKGBUILD
index 86cafdd72ce7..b9ef6f2c8f57 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,12 +6,16 @@ pkgdesc="RealLive clone for Linux and OSX. Git version."
arch=(i686 x86_64)
url="http://www.elliotglaysher.org/rlvm/"
license=('GPL')
-depends=('boost-libs>=1.46' glew libmad sdl_mixer sdl_image sdl_ttf guichan)
-makedepends=(scons boost)
+depends=('boost-libs>=1.46' glew libmad sdl_mixer sdl_image sdl_ttf guichan gtk2)
+makedepends=(git scons boost)
provides=(rlvm)
conflicts=(rlvm)
-source=('git+https://github.com/eglaysher/rlvm.git' 'detect_guichan.patch')
-md5sums=('SKIP' 'caf806e9f037ba95a747a0aefde7fd9d')
+source=('git+https://github.com/eglaysher/rlvm.git'
+ 'detect_guichan.patch'
+ 'freetype.patch')
+md5sums=('SKIP'
+ 'caf806e9f037ba95a747a0aefde7fd9d'
+ '60d11c6a9b259eda3ee69c6a6ddaffac')
pkgver() {
cd "$srcdir/rlvm/"
@@ -22,6 +26,7 @@ prepare() {
cd "$srcdir/rlvm/"
rm -r "$srcdir/rlvm/vendor/guichan"
patch -p1 < "$srcdir/detect_guichan.patch"
+ patch -p1 < "$srcdir/freetype.patch"
}
build() {
diff --git a/freetype.patch b/freetype.patch
new file mode 100644
index 000000000000..b53760afde7a
--- /dev/null
+++ b/freetype.patch
@@ -0,0 +1,13 @@
+diff --git a/SConstruct b/SConstruct
+index 9f2f4c8..2ebde4d 100644
+--- a/SConstruct
++++ b/SConstruct
+@@ -284,7 +284,7 @@ if not config.CheckGuichan():
+
+ # Get the configuration from sdl and freetype
+ env.ParseConfig("sdl-config --cflags")
+-env.ParseConfig("freetype-config --cflags --libs")
++env.ParseConfig("pkg-config --cflags freetype2")
+
+ env = config.Finish()
+