summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormaz-12015-10-15 08:49:18 +0800
committermaz-12015-10-15 08:49:18 +0800
commitb4a2b74abff2fdc0cb8713b87116c315775a837a (patch)
tree9d1123f643b18fc33146124208ead877e2ad37aa
parentc8a3c04171f78ad8934a48350ca95cc5decd9a9a (diff)
downloadaur-b4a2b74abff2fdc0cb8713b87116c315775a837a.tar.gz
fix
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--detect_guichan.patch21
3 files changed, 19 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 97f814cc9776..960aa3c8d62e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,7 +20,7 @@ pkgbase = rlvm-git
source = git+https://github.com/eglaysher/rlvm.git
source = detect_guichan.patch
md5sums = SKIP
- md5sums = 357e8680838cf8b27ab3c3eaa73d3107
+ md5sums = c15c493be8806c29b00d517e73617582
pkgname = rlvm-git
diff --git a/PKGBUILD b/PKGBUILD
index bd41a6f95b03..bdaefb89a42c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@ makedepends=(scons boost)
provides=(rlvm)
conflicts=(rlvm)
source=('git+https://github.com/eglaysher/rlvm.git' 'detect_guichan.patch')
-md5sums=('SKIP' '357e8680838cf8b27ab3c3eaa73d3107')
+md5sums=('SKIP' 'c15c493be8806c29b00d517e73617582')
pkgver() {
cd "$srcdir/rlvm/"
diff --git a/detect_guichan.patch b/detect_guichan.patch
index d57eedd97805..843d24b17320 100644
--- a/detect_guichan.patch
+++ b/detect_guichan.patch
@@ -1,14 +1,27 @@
diff -Naur a/SConstruct b/SConstruct
---- a/SConstruct 2015-10-14 00:57:12.750504352 +0000
-+++ b/SConstruct 2015-10-14 00:51:18.000000000 +0000
+--- a/SConstruct 2015-10-15 08:46:43.509294083 +0800
++++ b/SConstruct 2015-10-15 08:48:05.832442700 +0800
@@ -180,7 +180,9 @@
}
""", ".cc")[0]
if not ret:
- context.env.Replace(LIBS = lastLIBS)
-+ # context.env.Replace(LIBS = lastLIBS)
++ #context.env.Replace(LIBS = lastLIBS)
+ #fix for archlinux
-+ context.Message('(For some reason guichan is not detected, include anyway.)')
++ context.Message('(Somehow guichan is not detected, include anyway.)')
context.Result( ret )
return ret
+@@ -271,9 +273,9 @@
+ for library_dict in local_sdl_libraries:
+ CheckForSystemLibrary(config, library_dict, subcomponents)
+
+-if not config.CheckGuichan():
+- print "(Using included copy of guichan)"
+- subcomponents.append("guichan")
++#if not config.CheckGuichan():
++# print "(Using included copy of guichan)"
++# subcomponents.append("guichan")
+
+ # Get the configuration from sdl and freetype
+ env.ParseConfig("sdl-config --cflags")