summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorneeshy2024-07-03 18:14:22 -0400
committerneeshy2024-07-03 18:20:20 -0400
commitb5cbf4ffa3a16c4b4ae187c7ad3784f01e4b1994 (patch)
tree5e2b06480aaec2c533e5fdd66082f59a21be5b27
parenteda4a278821a41174f9391ca17dd65f69df9b976 (diff)
downloadaur-b5cbf4ffa3a16c4b4ae187c7ad3784f01e4b1994.tar.gz
add more patches
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--gtk+3.patch35
-rw-r--r--includes.patch (renamed from memory.patch)0
-rw-r--r--warnings.patch32
5 files changed, 81 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb151c8deddb..ad7c308d24ee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -22,8 +22,12 @@ pkgbase = rlvm-git
provides = rlvm
conflicts = rlvm
source = git+https://github.com/eglaysher/rlvm.git
- source = memory.patch
+ source = includes.patch
+ source = warnings.patch
+ source = gtk+3.patch
sha256sums = SKIP
sha256sums = 05b4c17fe4132b3877b53ba34076c4f21b0982d40ec134400697a51f7ea52226
+ sha256sums = 9e7d10880051c11062b67ca9ac5f53bf7277588228f0103e93ac6cccb72e57cc
+ sha256sums = 6bf8a1d8cd64b05057859338132acef11db573c58adc3913679776b8d4a7b83a
pkgname = rlvm-git
diff --git a/PKGBUILD b/PKGBUILD
index 5ef2e98201c5..58534ab7f60b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,9 +14,13 @@ makedepends=('git' 'scons' 'boost')
provides=('rlvm')
conflicts=('rlvm')
source=("git+https://github.com/eglaysher/rlvm.git"
- "memory.patch")
+ "includes.patch"
+ "warnings.patch"
+ "gtk+3.patch")
sha256sums=('SKIP'
- '05b4c17fe4132b3877b53ba34076c4f21b0982d40ec134400697a51f7ea52226')
+ '05b4c17fe4132b3877b53ba34076c4f21b0982d40ec134400697a51f7ea52226'
+ '9e7d10880051c11062b67ca9ac5f53bf7277588228f0103e93ac6cccb72e57cc'
+ '6bf8a1d8cd64b05057859338132acef11db573c58adc3913679776b8d4a7b83a')
pkgver() {
cd "$srcdir/$_pkgname"
@@ -25,7 +29,9 @@ pkgver() {
prepare() {
cd "$srcdir/$_pkgname"
- patch -Np1 -i "$srcdir/memory.patch"
+ patch -Np1 -i "$srcdir/includes.patch"
+ patch -Np1 -i "$srcdir/warnings.patch"
+ patch -Np1 -i "$srcdir/gtk+3.patch"
}
build() {
diff --git a/gtk+3.patch b/gtk+3.patch
new file mode 100644
index 000000000000..8a45f9f78168
--- /dev/null
+++ b/gtk+3.patch
@@ -0,0 +1,35 @@
+--- a/SConscript.gtk
++++ b/SConscript.gtk
+@@ -3,7 +3,7 @@
+ root_env = env.Clone()
+ root_env.Append(LIBS=["GL", "GLU"])
+ root_env.ParseConfig('sdl-config --cflags --libs')
+-root_env.ParseConfig('pkg-config --cflags --libs gtk+-2.0')
++root_env.ParseConfig('pkg-config --cflags --libs gtk+-3.0')
+
+ root_env.Append(
+ CXXFLAGS = [
+--- a/src/platforms/gtk/gtk_rlvm_instance.cc
++++ b/src/platforms/gtk/gtk_rlvm_instance.cc
+@@ -51,9 +51,6 @@
+ } // namespace
+
+ GtkRLVMInstance::GtkRLVMInstance(int* argc, char** argv[]) : RLVMInstance() {
+-#if defined ENABLE_NLS
+- gtk_set_locale();
+-#endif
+ gtk_init(argc, argv);
+
+ #if defined ENABLE_NLS
+@@ -69,9 +66,9 @@
+ GtkWidget* dialog = gtk_file_chooser_dialog_new(_("Select Game Directory"),
+ NULL,
+ GTK_FILE_CHOOSER_ACTION_OPEN,
+- GTK_STOCK_CANCEL,
++ _("_Cancel"),
+ GTK_RESPONSE_CANCEL,
+- GTK_STOCK_OPEN,
++ _("_Open"),
+ GTK_RESPONSE_ACCEPT,
+ NULL);
+
diff --git a/memory.patch b/includes.patch
index 6763df148d2f..6763df148d2f 100644
--- a/memory.patch
+++ b/includes.patch
diff --git a/warnings.patch b/warnings.patch
new file mode 100644
index 000000000000..bef771e31ba1
--- /dev/null
+++ b/warnings.patch
@@ -0,0 +1,32 @@
+--- a/src/libreallive/archive.cc
++++ b/src/libreallive/archive.cc
+@@ -132,7 +132,7 @@
+ void Archive::ReadOverrides() {
+ // Iterate over all files in the directory and override the table of contents
+ // if there is a free SEENXXXX.TXT file.
+- fs::path seen_dir = fs::path(name_).branch_path();
++ fs::path seen_dir = fs::path(name_).parent_path();
+ fs::directory_iterator end;
+ for (fs::directory_iterator it(seen_dir); it != end; ++it) {
+ std::string filename = it->path().filename().string();
+--- a/src/utilities/file.cc
++++ b/src/utilities/file.cc
+@@ -72,7 +72,7 @@
+ std::stack<std::string> pathElts;
+ while (!Path.empty() && !fs::exists(Path)) {
+ pathElts.push(Path.filename().string());
+- Path = Path.branch_path();
++ Path = Path.parent_path();
+ }
+ // Now proceed forwards through the possibly-incorrect elements.
+ while (!pathElts.empty()) {
+--- a/vendor/xclannad/file.cc
++++ b/vendor/xclannad/file.cc
+@@ -260,7 +260,6 @@
+ int real_region_count = 0;
+ std::set<REGION> unique_regions;
+ const char* head = _inbuf + 9;
+- bool overlaid_image = head_size > 1;
+ for (int i = 0; i < head_size; i++) {
+ region_table[i].x1 = read_little_endian_int(head+0);
+ region_table[i].y1 = read_little_endian_int(head+4);