summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSematre2022-11-12 11:41:10 +0100
committerSematre2022-11-12 11:41:10 +0100
commit01ed3e5422398981b7c57bc52d5d5f79f07b0145 (patch)
treebcd6428a762068e08e0999a8de901502ba7257bf
downloadaur-01ed3e5422398981b7c57bc52d5d5f79f07b0145.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7564d4f8ba8f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = rm2pdf
+ pkgdesc = Convert reMarkable tablet notebooks and annotated PDFs to layered PDF documents.
+ pkgver = 0.1.5
+ pkgrel = 1
+ url = https://github.com/rorycl/rm2pdf
+ arch = any
+ license = MIT
+ makedepends = go
+ source = rm2pdf-0.1.5.tar.gz::https://github.com/rorycl/rm2pdf/archive/refs/tags/v0.1.5.tar.gz
+ sha256sums = 6bacd90fa71630b9683df6a32ece19124a0b49ba072f5d63712952e81b1ef17a
+
+pkgname = rm2pdf
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb2ba562dca7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sematre <sematre at gmx dot de>
+pkgname=rm2pdf
+pkgver=0.1.5
+pkgrel=1
+
+pkgdesc="Convert reMarkable tablet notebooks and annotated PDFs to layered PDF documents."
+url="https://github.com/rorycl/${pkgname}"
+license=('MIT')
+arch=('any')
+
+makedepends=('go')
+
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('6bacd90fa71630b9683df6a32ece19124a0b49ba072f5d63712952e81b1ef17a')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ install -Dm 755 "${pkgname}" -t "${pkgdir}/usr/bin"
+ install -Dm 644 "LICENCE" -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}