summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattéo Delabre2019-02-16 14:33:09 +0100
committerMattéo Delabre2019-02-16 14:33:09 +0100
commit69c6bb1486c8331a55cf9ccfe8f8a59049642ff7 (patch)
treeb7e6a6ee54c0a10847dd07834bb891490b4dfafc
downloadaur-69c6bb1486c8331a55cf9ccfe8f8a59049642ff7.tar.gz
Release 0.0.4
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD42
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..349919aae352
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rmapi
+ pkgdesc = Access reMarkable tablet files through the Cloud API
+ pkgver = 0.0.4
+ pkgrel = 1
+ url = https://github.com/juruen/rmapi
+ arch = x86_64
+ license = GPL3
+ makedepends = go-pie
+ depends = glibc
+ source = https://github.com/juruen/rmapi/archive/v0.0.4.tar.gz
+ sha256sums = b3e57462a2158d828f37d5b5f0020d22f60d6212a2d70930ecf8d1593ac05277
+
+pkgname = rmapi
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59ee0a8a18c0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Mattéo Delabre <bonjour@matteodelabre.me>
+pkgname=rmapi
+pkgver=0.0.4
+pkgrel=1
+pkgdesc="Access reMarkable tablet files through the Cloud API"
+arch=('x86_64')
+url="https://github.com/juruen/rmapi"
+license=('GPL3')
+depends=('glibc')
+makedepends=('go-pie')
+source=("$url/archive/v$pkgver.tar.gz")
+sha256sums=('b3e57462a2158d828f37d5b5f0020d22f60d6212a2d70930ecf8d1593ac05277')
+
+_ref="${url#"https://"}"
+
+prepare() {
+ export GOPATH="$srcdir"/gopath
+ mkdir -p "$GOPATH"
+
+ ref_base="$(dirname "$_ref")"
+ mkdir -p "$GOPATH"/src/"$ref_base"
+ mv "$pkgname-$pkgver" "$GOPATH"/src/"$_ref"
+
+ cd "$GOPATH"/src/"$_ref"
+ go get -v -t -d -a ./...
+}
+
+build() {
+ export GOPATH="$srcdir"/gopath
+ cd "$GOPATH"/src/"$_ref"
+
+ go build \
+ -gcflags "all=-trimpath=$GOPATH" \
+ -asmflags "all=-trimpath=$GOPATH" \
+ -ldflags "-extldflags $LDFLAGS" \
+ -v .
+}
+
+package() {
+ cd "$GOPATH"/src/"$_ref"
+ install -Dm755 $pkgname "$pkgdir"/usr/bin/$pkgname
+}