summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFadeMind2015-07-21 16:27:44 +0200
committerFadeMind2015-07-21 16:27:44 +0200
commitfc4e43648aa864f64e3d1a783bb21b4d669cb903 (patch)
tree013243688eba8e804caaaff6e096170f1f4b2582
downloadaur-fc4e43648aa864f64e3d1a783bb21b4d669cb903.tar.gz
1.0.4-1
-rw-r--r--.SRCINFO14
-rw-r--r--ChangeLog3
-rw-r--r--PKGBUILD24
3 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..26d099522f2f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = rmdupe
+ pkgdesc = Removes duplicate files; supports trash, simulate, size, custom rm command
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/IgnorantGuru/rmdupe
+ changelog = ChangeLog
+ arch = any
+ license = GPL3
+ depends = bash
+ source = rmdupe-1.0.4.tar.xz::https://raw.githubusercontent.com/IgnorantGuru/rmdupe/master/packages/1.0.4/rmdupe-1.0.4.tar.xz
+ sha256sums = 548730c5530eb1036dea985846924307d9758564985477078cec468bf3fda05f
+
+pkgname = rmdupe
+
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..190fe8021042
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,3 @@
+# 1.0.4: fixed cannot remove filenames with special characters #2 #3
+# 1.0.3: corrected for stat %Z .000000000 bug
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ed1eea978d14
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer FadeMind <fademind@gmail.com>
+# Contributor: IgnorantGuru <ignorantguru@users.sourceforge.net>
+
+pkgname=rmdupe
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Removes duplicate files; supports trash, simulate, size, custom rm command"
+arch=('any')
+depends=("bash")
+license=('GPL3')
+url="https://github.com/IgnorantGuru/${pkgname}"
+changelog="ChangeLog"
+source=("${pkgname}-${pkgver}.tar.xz::https://raw.githubusercontent.com/IgnorantGuru/${pkgname}/master/packages/${pkgver}/${pkgname}-${pkgver}.tar.xz")
+sha256sums=('548730c5530eb1036dea985846924307d9758564985477078cec468bf3fda05f')
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -D -m755 "${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m644 "ChangeLog" "${pkgdir}/usr/share/doc/${pkgname}/ChangeLog"
+ install -D -m644 "COPYING" "${pkgdir}/usr/share/doc/${pkgname}/COPYING"
+ install -D -m644 "README" "${pkgdir}/usr/share/doc/${pkgname}/README"
+ install -D -m644 "COPYING" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+