summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2021-02-10 01:51:24 +0100
committerMassimiliano Torromeo2021-02-10 01:51:24 +0100
commit7acfb9377106ddbccaca039aa523f3ebba11357e (patch)
tree46d3ace3cbc8eb1fc91101727a99a0b7d8018e1f
downloadaur-7acfb9377106ddbccaca039aa523f3ebba11357e.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD24
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8365c818bdeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = rmfuse
+ pkgdesc = FUSE access to the reMarkable Cloud
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/rschroll/rmfuse/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-pyfuse3
+ depends = python-bidict
+ depends = python-rmcl
+ depends = python-rmrl
+ source = https://files.pythonhosted.org/packages/source/r/rmfuse/rmfuse-0.1.1.tar.gz
+ sha256sums = 358454373e505a56b8645b7f15d42f0ec118ccf28d3e3e8f4530210ddb67cf22
+
+pkgname = rmfuse
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d0ad39874237
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=rmfuse
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="FUSE access to the reMarkable Cloud"
+arch=(any)
+url="https://github.com/rschroll/rmfuse/"
+license=('MIT')
+depends=('python-pyfuse3' 'python-bidict' 'python-rmcl' 'python-rmrl')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/r/rmfuse/rmfuse-$pkgver.tar.gz")
+sha256sums=('358454373e505a56b8645b7f15d42f0ec118ccf28d3e3e8f4530210ddb67cf22')
+
+build() {
+ cd "$srcdir"/rmfuse-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/rmfuse-$pkgver
+ python setup.py install -O1 --skip-build --root="$pkgdir"
+ install -Dm0644 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}