summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2021-04-26 16:30:39 -0400
committerCebtenzzre2021-04-26 16:30:48 -0400
commit4ba0b70c24b65937a10d5e1dda8e564514c52484 (patch)
tree1febb4ffa2c12a11d5015d56b18c969616db4cf3
downloadaur-4ba0b70c24b65937a10d5e1dda8e564514c52484.tar.gz
Initial commit
-rw-r--r--.SRCINFO44
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD55
3 files changed, 100 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ae314c92bed7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,44 @@
+pkgbase = rmlint-develop-git
+ pkgver = 2.10.1.r210.g1ab4d8ae
+ pkgrel = 1
+ url = https://github.com/sahib/rmlint
+ arch = x86_64
+ license = GPL3
+ makedepends = binutils
+ makedepends = dconf
+ makedepends = desktop-file-utils
+ makedepends = gettext
+ makedepends = git
+ makedepends = gtksourceview3
+ makedepends = json-glib
+ makedepends = libelf
+ makedepends = librsvg
+ makedepends = python-cairo
+ makedepends = python-gobject
+ makedepends = python-requests
+ makedepends = python-sphinx
+ makedepends = scons
+ makedepends = util-linux-libs
+ makedepends = xdg-utils
+ provides = rmlint=2.10.1.r210.g1ab4d8ae
+ conflicts = rmlint
+ source = git+https://github.com/sahib/rmlint.git#branch=develop
+ md5sums = SKIP
+
+pkgname = rmlint-develop-git
+ pkgdesc = Tool to remove duplicates and other lint, being much faster than fdupes
+ depends = binutils
+ depends = json-glib
+ depends = libelf
+ depends = util-linux-libs
+
+pkgname = rmlint-shredder-develop-git
+ pkgdesc = Graphical user interface for rmlint
+ depends = dconf
+ depends = gtksourceview3
+ depends = librsvg
+ depends = python-cairo
+ depends = python-gobject
+ depends = rmlint-develop-git
+ depends = xdg-utils
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f6f39765a774
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,55 @@
+# Maintainer: Cebtenzzre <cebtenzzre (AT) gmail (DOT) com>
+# Contributor: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+# Contributor: Blisfull <narthana.epa@gmail.com>
+# Contributor: SahibBommelig <sahib@online.de>
+
+_pkgname=rmlint
+pkgbase=${_pkgname}-develop-git
+pkgname=(rmlint-develop-git rmlint-shredder-develop-git)
+pkgver=2.10.1.r210.g1ab4d8ae
+pkgrel=1
+url="https://github.com/sahib/rmlint"
+license=('GPL3')
+arch=('x86_64')
+makedepends=('binutils' 'dconf' 'desktop-file-utils' 'gettext' 'git'
+ 'gtksourceview3' 'json-glib' 'libelf' 'librsvg' 'python-cairo'
+ 'python-gobject' 'python-requests' 'python-sphinx' 'scons'
+ 'util-linux-libs' 'xdg-utils')
+provides=("${_pkgname}=${pkgver}")
+conflicts=("$_pkgname")
+source=("git+https://github.com/sahib/${_pkgname}.git#branch=develop")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ git describe --long | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "$_pkgname"
+ scons config
+ scons -j4 DEBUG=1 --prefix="$pkgdir"/usr --actual-prefix=/usr
+}
+
+package_rmlint-develop-git() {
+ pkgdesc="Tool to remove duplicates and other lint, being much faster than fdupes"
+ depends=('binutils' 'json-glib' 'libelf' 'util-linux-libs')
+
+ cd "$_pkgname"
+ scons DEBUG=1 --prefix="$pkgdir"/usr install --actual-prefix=/usr
+
+ rm -rf "$pkgdir"/usr/share/{glib-2.0,icons,applications}
+ rm -rf "$pkgdir"/usr/lib
+}
+
+package_rmlint-shredder-develop-git() {
+ pkgdesc="Graphical user interface for rmlint"
+ depends=('dconf' 'gtksourceview3' 'librsvg' 'python-cairo' 'python-gobject'
+ 'rmlint-develop-git' 'xdg-utils')
+
+ cd "$_pkgname"
+ scons DEBUG=1 --prefix="$pkgdir"/usr install --actual-prefix=/usr
+
+ rm -rf "$pkgdir"/usr/{bin,share/locale,share/man}
+ rm "$pkgdir"/usr/share/glib-2.0/schemas/gschemas.compiled
+}