summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2021-04-26 17:06:14 -0400
committerCebtenzzre2021-04-26 17:06:14 -0400
commitef70f04657b26afd144f1399abce56620f62b58d (patch)
tree74d93f3ab936eab61973ef14448592db2c039587
parent4ba0b70c24b65937a10d5e1dda8e564514c52484 (diff)
downloadaur-ef70f04657b26afd144f1399abce56620f62b58d.tar.gz
Separate provides and conflicts for each package
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ae314c92bed7..26760211342a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -20,8 +20,6 @@ pkgbase = rmlint-develop-git
makedepends = scons
makedepends = util-linux-libs
makedepends = xdg-utils
- provides = rmlint=2.10.1.r210.g1ab4d8ae
- conflicts = rmlint
source = git+https://github.com/sahib/rmlint.git#branch=develop
md5sums = SKIP
@@ -31,6 +29,8 @@ pkgname = rmlint-develop-git
depends = json-glib
depends = libelf
depends = util-linux-libs
+ provides = rmlint=2.10.1.r210.g1ab4d8ae
+ conflicts = rmlint
pkgname = rmlint-shredder-develop-git
pkgdesc = Graphical user interface for rmlint
@@ -41,4 +41,6 @@ pkgname = rmlint-shredder-develop-git
depends = python-gobject
depends = rmlint-develop-git
depends = xdg-utils
+ provides = rmlint-shredder=2.10.1.r210.g1ab4d8ae
+ conflicts = rmlint-shredder
diff --git a/PKGBUILD b/PKGBUILD
index f6f39765a774..3fe2b94f4a23 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,6 @@ makedepends=('binutils' 'dconf' 'desktop-file-utils' 'gettext' 'git'
'gtksourceview3' 'json-glib' 'libelf' 'librsvg' 'python-cairo'
'python-gobject' 'python-requests' 'python-sphinx' 'scons'
'util-linux-libs' 'xdg-utils')
-provides=("${_pkgname}=${pkgver}")
-conflicts=("$_pkgname")
source=("git+https://github.com/sahib/${_pkgname}.git#branch=develop")
md5sums=('SKIP')
@@ -34,6 +32,8 @@ build() {
package_rmlint-develop-git() {
pkgdesc="Tool to remove duplicates and other lint, being much faster than fdupes"
depends=('binutils' 'json-glib' 'libelf' 'util-linux-libs')
+ provides=("${_pkgname}=${pkgver}")
+ conflicts=("$_pkgname")
cd "$_pkgname"
scons DEBUG=1 --prefix="$pkgdir"/usr install --actual-prefix=/usr
@@ -46,6 +46,8 @@ package_rmlint-shredder-develop-git() {
pkgdesc="Graphical user interface for rmlint"
depends=('dconf' 'gtksourceview3' 'librsvg' 'python-cairo' 'python-gobject'
'rmlint-develop-git' 'xdg-utils')
+ provides=("rmlint-shredder=${pkgver}")
+ conflicts=('rmlint-shredder')
cd "$_pkgname"
scons DEBUG=1 --prefix="$pkgdir"/usr install --actual-prefix=/usr