summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChris P2015-09-22 18:08:53 +0200
committerChris P2015-09-22 18:08:53 +0200
commit285b8cd9dd9aa372f19be8eb48d97d77963bec31 (patch)
treef181879df0333f349245aba76068ef07956ed216
parent15d0259659b9c8296b193bd68630dd2311ebc269 (diff)
downloadaur-285b8cd9dd9aa372f19be8eb48d97d77963bec31.tar.gz
Add conflict('rmlint') and use a more sane pkgver()
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3459122d81bf..6326004b7b76 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rmlint-git
pkgdesc = Tool to remove duplicates and other lint, being much faster than fdupes
- pkgver = 967.812a5d5
- pkgrel = 3
+ pkgver = v2.2.0.r33.g08a75ed
+ pkgrel = 1
url = https://github.com/sahib/rmlint
arch = i686
arch = x86_64
@@ -13,7 +13,10 @@ pkgbase = rmlint-git
depends = glib2>=2.31
depends = libutil-linux
depends = elfutils
+ depends = gettext
+ depends = json-glib
provides = rmlint
+ conflicts = rmlint
source = rmlint-git::git+https://github.com/sahib/rmlint.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 1c53cfd01200..e3c3fd3b88a9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,26 +3,26 @@
_pkgname=rmlint
pkgname=${_pkgname}-git
-pkgver=967.812a5d5
-pkgrel=3
+pkgver=v2.2.0.r33.g08a75ed
+pkgrel=1
pkgdesc="Tool to remove duplicates and other lint, being much faster than fdupes"
arch=('i686' 'x86_64')
url="https://github.com/sahib/rmlint"
license=('GPL3')
-depends=('glibc' 'glib2>=2.31' 'libutil-linux' 'elfutils')
+depends=('glibc' 'glib2>=2.31' 'libutil-linux' 'elfutils' 'gettext' 'json-glib')
makedepends=('git' 'scons' 'python-sphinx')
+conflicts=("${_pkgname}")
provides=("$_pkgname")
source=("$pkgname"::"git+https://github.com/sahib/${_pkgname}.git")
md5sums=('SKIP')
pkgver() {
cd "${srcdir}/${pkgname}"
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ git describe --long | sed 's/^foo-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "${srcdir}/${pkgname}"
- scons config
scons -j4 DEBUG=1 --prefix=${pkgdir}/usr --actual-prefix=/usr
}