summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorspoons2021-11-10 00:39:41 -0500
committerspoons2021-11-10 00:40:25 -0500
commit647a443b70b75b178b5505196f27eaae553a707b (patch)
tree3beb78b1720042afee1028479b066516993755d6
downloadaur-647a443b70b75b178b5505196f27eaae553a707b.tar.gz
feat: adds PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO21
-rw-r--r--ChangeLog83
-rw-r--r--PKGBUILD36
3 files changed, 140 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..56035f43bea9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = rmm-git
+ pkgdesc = RimWorld Mod Manager
+ pkgver = 0.0.7.r4.g2ed8a48
+ pkgrel = 1
+ url = https://github.com/Spoons/rmm.git
+ changelog = ChangeLog
+ arch = any
+ license = GPL
+ makedepends = git
+ makedepends = python-setuptools
+ depends = steamcmd
+ depends = python
+ depends = python-beautifulsoup4
+ depends = python-tabulate
+ depends = python-docopt
+ provides = rmm
+ conflicts = rmm
+ source = rmm-git::git+https://github.com/Spoons/rmm.git
+ md5sums = SKIP
+
+pkgname = rmm-git
diff --git a/ChangeLog b/ChangeLog
new file mode 100644
index 000000000000..41cfa2b1eb41
--- /dev/null
+++ b/ChangeLog
@@ -0,0 +1,83 @@
+CHANGES
+=======
+
+v0.0.8
+------
+
+* fix: exception on import command
+* feat: adds PKGBUILD and zsh/bash completions
+* fix: removed more\_magic for docopt (non-ng) compatibility
+* feat: add issue template
+* feat: add changelog and authors
+
+v0.0.7
+------
+
+* feat: use pbr for package management
+* fix: correctly detect duplicated mods during sync
+* fix: mod pathing detection fix
+
+v0.0.6
+------
+
+* fix: update\_all\_mods hotfix
+* v0.0.6 release
+* fix: improve performance
+* fix: multiple fixes for mod folder management
+* fix: add missing operations to help string
+* feat: improve readme clarity
+
+v0.0.5
+------
+
+* feat: v0.0.5 release
+* feat: improved cli and code refactor
+
+v0.0.4
+------
+
+* feat: v0.0.4 release
+* feat: add migrate and version command
+* fix: remove debug print during collision detection
+* feat[readme]: add RMM\_WORKSHOP\_PATH info
+
+v0.0.3
+------
+
+* feat: bump for v0.0.3 release
+* feat: selects temp directory atomically
+* feat: support for steam rimworld and workshop
+
+v0.0.2
+------
+
+* feat: bump for 0.0.2 release
+* fix[core]: fixes multiple issues regarding cache
+* feat: patch release
+* fix: installation logic, ui hang, file performance
+* fix[readme]: install package name match pypi
+
+v0.0.1
+------
+
+* feat: increment version for first release
+* fix[doc]: fix incorrect install documentation
+* fix: corrects setuptools runtime deps
+* fix: list not printing table
+* fix: add deps to packaging
+* feat: add mod name and author to mod lists
+* feat: add variable arguments to sync commands
+* fix: update README
+* feat: check default RimWorld paths
+* feat[cli]: add query (local search)
+* feat[cli]: add mod removal
+* feat: ignore files that are not mod directories
+* feat: add setuptools packaging
+* feat: add README and requirements.txt
+* fix: style code
+* fix: require RMM\_MOD to be set
+* fix: validate interactive sync package selection
+* feat: add package cache seperation and mod list importing
+* feat: add interactive sync and search command
+* feat: add command line interface and usage
+* feat: add workshop mod download functionality
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea86cc96e3f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: childofunix at gmail dot com
+
+pkgname="rmm-git"
+pkgver=0.0.8
+pkgrel=1
+pkgdesc="RimWorld Mod Manager"
+arch=("any")
+url="https://github.com/Spoons/rmm.git"
+license=("GPL")
+depends=("steamcmd" "python" "python-beautifulsoup4" "python-tabulate" "python-docopt")
+makedepends=("git" "python-setuptools")
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+changelog=ChangeLog
+source=("$pkgname::git+$url")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ git describe --tags | sed "s/^v//;s/\([^-]*-g\)/r\1/;s/-/./g"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm 644 ChangeLog -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm 755 comp/_rmm -t "$pkgdir/usr/share/zsh/functions/Completion/"
+ install -Dm 755 comp/rmm.sh -t "$pkgdir/etc/bash_completion.d/rmm.sh"
+}