summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSanskritFritz2019-09-12 16:54:44 +0200
committerSanskritFritz2019-09-12 16:54:44 +0200
commit6da88642918854611f2c12a35906893941af7de0 (patch)
treefb5dd935fed2988afbc4f80f714b5134634f16c6
downloadaur-6da88642918854611f2c12a35906893941af7de0.tar.gz
Upstream version 1.0.0
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD39
-rw-r--r--rnd_jue_ii.desktop8
-rwxr-xr-xrnd_jue_ii.sh4
4 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ac4f0ddbb329
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = rnd_jue_ii
+ pkgdesc = A remake of the game Rocks'n'Diamonds.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://www.jb-line.de/rnd17/17start_e.html
+ arch = x86_64
+ license = GPL2
+ depends = sdl2_image
+ depends = sdl2_mixer
+ depends = sdl2_net
+ depends = smpeg
+ source = http://www.jb-line.de/rnd17/dat/rndjue_II-1.0.0.tar.gz
+ source = rnd_jue_ii.desktop
+ source = rnd_jue_ii.sh
+ md5sums = b491e177a8e60273ba39a3bfa2d6ec3b
+ md5sums = d482985e35cedf1ac489b26e83c66441
+ md5sums = 080002ed407306f26c96ef5ade6ba9c2
+
+pkgname = rnd_jue_ii
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2208959a5d82
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: SanskritFritz (gmail)
+
+pkgname=rnd_jue_ii
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="A remake of the game Rocks'n'Diamonds."
+arch=('x86_64')
+url="http://www.jb-line.de/rnd17/17start_e.html"
+license=('GPL2')
+depends=('sdl2_image' 'sdl2_mixer' 'sdl2_net' 'smpeg')
+
+source=("http://www.jb-line.de/rnd17/dat/rndjue_II-$pkgver.tar.gz"
+ "rnd_jue_ii.desktop" "rnd_jue_ii.sh")
+
+md5sums=('b491e177a8e60273ba39a3bfa2d6ec3b'
+ 'd482985e35cedf1ac489b26e83c66441'
+ '080002ed407306f26c96ef5ade6ba9c2')
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+# make RO_GAME_DIR="/usr/share/${pkgname}" RW_GAME_DIR=~/.${pkgname}
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ install -dm755 "${pkgdir}/usr/share/${pkgname}"
+ cp -r rocksndiamonds rnd_jue_ii graphics levels music sounds docs conf "${pkgdir}/usr/share/${pkgname}"
+
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 ChangeLog CREDITS INSTALL COPYING "${pkgdir}/usr/share/doc/${pkgname}"
+
+ install -D -m644 "${srcdir}/${pkgname}.desktop" "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+ install -D -m755 "${srcdir}/${pkgname}.sh" "${pkgdir}/usr/bin/${pkgname}"
+
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/rnd_jue_ii.desktop b/rnd_jue_ii.desktop
new file mode 100644
index 000000000000..937413138eb6
--- /dev/null
+++ b/rnd_jue_ii.desktop
@@ -0,0 +1,8 @@
+[Desktop Entry]
+Type=Application
+Name=R'n'D Jue II
+Comment=R'n'D Jue II A remake of the game Rocks'n'Diamonds
+Exec=rnd_jue_ii
+Terminal=false
+Categories=Application;Game;
+Icon=/usr/share/rnd_jue_ii/graphics/jue64/icon.png
diff --git a/rnd_jue_ii.sh b/rnd_jue_ii.sh
new file mode 100755
index 000000000000..2eb2a215811e
--- /dev/null
+++ b/rnd_jue_ii.sh
@@ -0,0 +1,4 @@
+#!/usr/bin/bash
+
+cd /usr/share/rnd_jue_ii
+./rocksndiamonds