summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo2021-10-24 10:03:58 +0800
committerLeo2021-10-24 10:03:58 +0800
commit386e7ad6621719ff6bc93344b7e9f2bc392393e5 (patch)
tree485ca19ffe1ee00aa7b9a11f3a83e9e7ed9d99a4
parent3599f03bcdb12a3c884a090f7e1654c9059041ad (diff)
downloadaur-386e7ad6621719ff6bc93344b7e9f2bc392393e5.tar.gz
New upstream version 2.5.2
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
2 files changed, 8 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59ad7df3332a..5b2b36a383b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = roadrunner
pkgdesc = High-performance PHP application server, load-balancer and process manager written in Golang
- pkgver = 2.5.0
+ pkgver = 2.5.2
pkgrel = 1
url = https://roadrunner.dev/
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = roadrunner
depends = php>=7.3
options = !buildflags
source = roadrunner-2.5.0.tar.gz::https://github.com/spiral/roadrunner/archive/v2.5.0.tar.gz
- source = roadrunner-binary-2.5.0.tar.gz::https://github.com/spiral/roadrunner-binary/archive/v2.5.0.tar.gz
+ source = roadrunner-binary-2.5.2.tar.gz::https://github.com/spiral/roadrunner-binary/archive/v2.5.2.tar.gz
source = .rr.yaml.sample-full
source = .rr.yaml.sample-minimal
sha256sums = a04dd6b333e1b6d942d5a4611dbc8b4352f227288598e33748d225c11dec6118
- sha256sums = 35b866f0ae1731e1a2d15ee83a076d15558e3fae7e245feb6269b442ff933cb3
+ sha256sums = bf9da2b20f49db395d29887327f742962f53a99a1c923995aa7ac6228095d02b
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index b786206a2e9e..0b1a19aafc4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,8 @@
# Maintainer: Leo <i@setuid0.dev>
pkgname=roadrunner
-pkgver=2.5.0
+pkgver=2.5.2
+_rr_ver=2.5.0
pkgrel=1
pkgdesc="High-performance PHP application server, load-balancer and process manager written in Golang"
arch=(x86_64)
@@ -10,14 +11,14 @@ license=(MIT)
depends=("php>=7.3")
makedepends=("go>=1.16")
source=(
- "$pkgname-$pkgver.tar.gz::https://github.com/spiral/$pkgname/archive/v$pkgver.tar.gz"
+ "$pkgname-$_rr_ver.tar.gz::https://github.com/spiral/$pkgname/archive/v$_rr_ver.tar.gz"
"$pkgname-binary-$pkgver.tar.gz::https://github.com/spiral/$pkgname-binary/archive/v$pkgver.tar.gz"
".rr.yaml.sample-full"
".rr.yaml.sample-minimal"
)
sha256sums=(
'a04dd6b333e1b6d942d5a4611dbc8b4352f227288598e33748d225c11dec6118'
- '35b866f0ae1731e1a2d15ee83a076d15558e3fae7e245feb6269b442ff933cb3'
+ 'bf9da2b20f49db395d29887327f742962f53a99a1c923995aa7ac6228095d02b'
SKIP
SKIP
)
@@ -27,7 +28,7 @@ prepare() {
export GOPATH="$srcdir"/gopath
cd "$srcdir/$pkgname-binary-$pkgver"
- go mod edit -replace "github.com/spiral/roadrunner/v2=../roadrunner-$pkgver"
+ go mod edit -replace "github.com/spiral/roadrunner/v2=../roadrunner-$_rr_ver"
go mod tidy
go mod download
}
@@ -51,9 +52,6 @@ build() {
}
check() {
- cd "$srcdir/$pkgname-$pkgver"
- make test_coverage
-
cd "$srcdir/$pkgname-binary-$pkgver"
go test -race -covermode=atomic -coverprofile ./coverage.txt ./...
}