summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo2020-12-28 01:03:36 +0800
committerLeo2020-12-28 01:03:36 +0800
commit5000f04e3fe09611ad3e2b8df453e8ef3af2fece (patch)
tree73a06ea0f2a023d7c93a8227da0e0b7206242932
parent3bd2b5e5b00cdc1acb6fff13ed89797e7a5a8394 (diff)
downloadaur-5000f04e3fe09611ad3e2b8df453e8ef3af2fece.tar.gz
New upstream version 1.9.1
* apply patch for build version and time * rename package and conflicts with the patched version
-rw-r--r--.SRCINFO9
-rw-r--r--02-build_version_time.patch25
-rw-r--r--PKGBUILD9
3 files changed, 38 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa2cd1d2007e..a04ea3996bbd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
pkgbase = roadrunner
pkgdesc = High-performance PHP application server, load-balancer and process manager written in Golang
- pkgver = 1.9.0
+ pkgver = 1.9.1
pkgrel = 1
url = https://roadrunner.dev/
arch = x86_64
license = MIT
makedepends = go>=1.13
depends = php>=7.3
+ conflicts = roadrunner-leo-patched
options = !buildflags
- source = https://github.com/spiral/roadrunner/archive/v1.9.0.tar.gz
+ source = https://github.com/spiral/roadrunner/archive/v1.9.1.tar.gz
source = .rr.yaml.sample-full
source = .rr.yaml.sample-minimal
- sha256sums = ee306cce2132c8f0b0dbd3a085084194f7c8659ae50a87ea06c160d4f2c716c4
+ source = 02-build_version_time.patch
+ sha256sums = 4e11dd50d2d1a645b4eace027ed48c7dcfb8bfaba82100c5476e1a75f6188433
+ sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/02-build_version_time.patch b/02-build_version_time.patch
new file mode 100644
index 000000000000..e8445b515f0f
--- /dev/null
+++ b/02-build_version_time.patch
@@ -0,0 +1,25 @@
+diff --git a/Makefile b/Makefile
+index 9ad158b..96393c4 100755
+--- a/Makefile
++++ b/Makefile
+@@ -4,6 +4,11 @@
+
+ SHELL = /bin/sh
+
++RR_VERSION = 1.9.1
++
++LDFLAGS += -X github.com/spiral/roadrunner/cmd/rr/cmd.Version=${RR_VERSION}
++LDFLAGS += -X github.com/spiral/roadrunner/cmd/rr/cmd.BuildTime=$(shell date +%FT%T%z)
++
+ .DEFAULT_GOAL := build
+
+ # This will output the help for each task. thanks to https://marmelab.com/blog/2016/02/29/auto-documented-makefile.html
+@@ -12,7 +17,7 @@ help: ## Show this help
+ @awk 'BEGIN {FS = ":.*?## "} /^[a-zA-Z0-9_-]+:.*?## / {printf " \033[32m%-14s\033[0m %s\n", $$1, $$2}' $(MAKEFILE_LIST)
+
+ build: ## Build RR binary file for local os/arch
+- CGO_ENABLED=0 go build -trimpath -ldflags "-s" -o ./rr ./cmd/rr/main.go
++ CGO_ENABLED=0 go build -trimpath -ldflags "${LDFLAGS} -s" -o ./rr ./cmd/rr/main.go
+
+ clean: ## Make some clean
+ rm ./rr
diff --git a/PKGBUILD b/PKGBUILD
index 71034f1fd001..28e02a69d364 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leo <i@setuid0.dev>
pkgname=roadrunner
-pkgver=1.9.0
+pkgver=1.9.1
pkgrel=1
pkgdesc="High-performance PHP application server, load-balancer and process manager written in Golang"
arch=(x86_64)
@@ -13,14 +13,19 @@ source=(
"https://github.com/spiral/$pkgname/archive/v$pkgver.tar.gz"
".rr.yaml.sample-full"
".rr.yaml.sample-minimal"
+ "02-build_version_time.patch"
)
sha256sums=(
- "ee306cce2132c8f0b0dbd3a085084194f7c8659ae50a87ea06c160d4f2c716c4"
+ "4e11dd50d2d1a645b4eace027ed48c7dcfb8bfaba82100c5476e1a75f6188433"
+ SKIP
SKIP
SKIP
)
options=("!buildflags")
+# Won't allow installing of both patched and original version.
+conflicts=("roadrunner-leo-patched")
+
build() {
export GOPATH="$srcdir"/gopath
export CGO_CPPFLAGS="${CPPFLAGS}"