summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo2021-01-17 16:50:22 +0800
committerLeo2021-01-17 16:50:22 +0800
commit7ec34572284e60d7f42040f481dd2e5d1a44b121 (patch)
tree78207b92afc54622fd6909af1caf77191a13eb3d
parent5000f04e3fe09611ad3e2b8df453e8ef3af2fece (diff)
downloadaur-7ec34572284e60d7f42040f481dd2e5d1a44b121.tar.gz
New upstream version 1.9.2
-rw-r--r--.SRCINFO8
-rw-r--r--.rr.yaml.sample-full16
-rw-r--r--03-build_version_time.patch (renamed from 02-build_version_time.patch)0
-rw-r--r--PKGBUILD9
4 files changed, 9 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a04ea3996bbd..ecda00b27f1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = roadrunner
pkgdesc = High-performance PHP application server, load-balancer and process manager written in Golang
- pkgver = 1.9.1
+ pkgver = 1.9.2
pkgrel = 1
url = https://roadrunner.dev/
arch = x86_64
@@ -9,11 +9,11 @@ pkgbase = roadrunner
depends = php>=7.3
conflicts = roadrunner-leo-patched
options = !buildflags
- source = https://github.com/spiral/roadrunner/archive/v1.9.1.tar.gz
+ source = https://github.com/spiral/roadrunner/archive/v1.9.2.tar.gz
source = .rr.yaml.sample-full
source = .rr.yaml.sample-minimal
- source = 02-build_version_time.patch
- sha256sums = 4e11dd50d2d1a645b4eace027ed48c7dcfb8bfaba82100c5476e1a75f6188433
+ source = 03-build_version_time.patch
+ sha256sums = b49f082391380ac66e1e90f147594d7c3772a3b9eddb042f04b338083ae40e33
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.rr.yaml.sample-full b/.rr.yaml.sample-full
index 5bd586f81f27..edfed480dd9f 100644
--- a/.rr.yaml.sample-full
+++ b/.rr.yaml.sample-full
@@ -25,22 +25,6 @@ http:
# http host to listen.
address: 0.0.0.0:8080
- ssl:
- # custom https port (default 443)
- port: 443
-
- # force redirect to https connection
- redirect: true
-
- # ssl cert
- cert: server.crt
-
- # ssl private key
- key: server.key
-
- # rootCA certificate path
- rootCa: root.crt
-
# HTTP service provides FastCGI as frontend
fcgi:
# FastCGI connection DSN. Supported TCP and Unix sockets.
diff --git a/02-build_version_time.patch b/03-build_version_time.patch
index e8445b515f0f..e8445b515f0f 100644
--- a/02-build_version_time.patch
+++ b/03-build_version_time.patch
diff --git a/PKGBUILD b/PKGBUILD
index 28e02a69d364..d798eb05c602 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Leo <i@setuid0.dev>
pkgname=roadrunner
-pkgver=1.9.1
+pkgver=1.9.2
pkgrel=1
pkgdesc="High-performance PHP application server, load-balancer and process manager written in Golang"
arch=(x86_64)
@@ -13,10 +13,10 @@ source=(
"https://github.com/spiral/$pkgname/archive/v$pkgver.tar.gz"
".rr.yaml.sample-full"
".rr.yaml.sample-minimal"
- "02-build_version_time.patch"
+ "03-build_version_time.patch"
)
sha256sums=(
- "4e11dd50d2d1a645b4eace027ed48c7dcfb8bfaba82100c5476e1a75f6188433"
+ "b49f082391380ac66e1e90f147594d7c3772a3b9eddb042f04b338083ae40e33"
SKIP
SKIP
SKIP
@@ -33,7 +33,8 @@ build() {
export CGO_CXXFLAGS="${CXXFLAGS}"
export CGO_LDFLAGS="${LDFLAGS}"
cd "$pkgname-$pkgver"
- go mod download -x
+ patch -p1 < $srcdir/03-build_version_time.patch
+ go mod download
make
}