summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBenoit Brummer2018-05-11 02:36:02 +0200
committerBenoit Brummer2018-05-11 02:36:02 +0200
commita52680db9df6221f71c3fe740bfb46c7d9f0f661 (patch)
treecf68a32d966fe7e9f3d1e338399a6082decfec8e
downloadaur-a52680db9df6221f71c3fe740bfb46c7d9f0f661.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8c2947fc4b7f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = roboschool-git
+ pkgdesc = Robot simulation, integrated with OpenAI Gym.
+ pkgver = r242.675f1ac4
+ pkgrel = 1
+ url = https://github.com/openai/roboschool
+ arch = any
+ license = MIT
+ makedepends = cmake
+ makedepends = python-setuptools
+ makedepends = boost
+ depends = python-gym-git
+ depends = qt5-base
+ depends = assimp
+ depends = tinyxml
+ source = git+https://github.com/openai/roboschool.git
+ source = git+https://github.com/olegklimov/bullet3#branch=roboschool_self_collision
+ sha256sums = SKIP
+ sha256sums = SKIP
+
+pkgname = roboschool-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..42efff0d1dd3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: trougnouf (Benoit Brummer) <trougnouf at gmail dot com>
+
+_name='roboschool'
+pkgname="${_name}-git"
+pkgver=r242.675f1ac4
+pkgrel=1
+pkgdesc='Robot simulation, integrated with OpenAI Gym.'
+url="https://github.com/openai/${_name}"
+depends=('python-gym-git' 'qt5-base' 'assimp' 'tinyxml')
+makedepends=('cmake' 'python-setuptools' 'boost')
+license=('MIT')
+arch=('any')
+
+
+pkgver() {
+ cd "$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+source=("git+${url}.git"
+ "git+https://github.com/olegklimov/bullet3#branch=${_name}_self_collision")
+
+sha256sums=('SKIP' 'SKIP')
+
+build() {
+ cd "${srcdir}/roboschool/roboschool/cpp-household"
+ sed -i -e s/\$\(BOOST_PYTHON3_POSTFIX\)//g Makefile
+ mkdir -p "${srcdir}/bullet3/build"
+ cd "${srcdir}/bullet3/build"
+ cmake -DBUILD_SHARED_LIBS=ON -DUSE_DOUBLE_PRECISION=1 -DCMAKE_INSTALL_PREFIX:PATH=${srcdir}/${_name}/${_name}/cpp-household/bullet_local_install -DBUILD_CPU_DEMOS=OFF -DBUILD_BULLET2_DEMOS=OFF -DBUILD_EXTRAS=OFF -DBUILD_UNIT_TESTS=OFF -DBUILD_CLSOCKET=OFF -DBUILD_ENET=OFF -DBUILD_OPENGL3_DEMOS=OFF ..
+ make
+ make install
+ cd ${srcdir}/${_name}
+ python setup.py build
+}
+
+package() {
+ #cd "${srcdir}/bullet3/build"
+ #make install
+ cd "${srcdir}/${_name}"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}