summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamuel Bernard2020-04-27 16:33:19 +0200
committerSamuel Bernard2020-04-28 16:14:59 +0200
commit77af94e391c4c41bf49320cc2bdbf58534147704 (patch)
tree244190eec27ef2b77e0968a420597751c050b19f
parent957866bef6f017630a0a942982d53bd2bfaf4cca (diff)
downloadaur-77af94e391c4c41bf49320cc2bdbf58534147704.tar.gz
rocblas: build with tensile
Also use python for makedep instead of python2
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cdb60663730a..68a23da6fec1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = rocblas
pkgdesc = Next generation BLAS implementation for ROCm platform
pkgver = 3.3.0
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/ROCmSoftwarePlatform/rocBLAS
arch = x86_64
license = custom:NCSAOSL
makedepends = cmake
makedepends = hcc>=3.3.0
- makedepends = python2
+ makedepends = python
makedepends = boost
makedepends = comgr>=3.3.0
makedepends = rocminfo
diff --git a/PKGBUILD b/PKGBUILD
index 64d3fb6413ea..7c814bf12b82 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,13 @@
pkgname=rocblas
_pkgver=3.3.0
pkgver="$_pkgver"
-pkgrel=2
+pkgrel=3
pkgdesc="Next generation BLAS implementation for ROCm platform"
arch=('x86_64')
url="https://github.com/ROCmSoftwarePlatform/rocBLAS"
license=('custom:NCSAOSL')
depends=('hcc' 'hip')
-makedepends=('cmake' "hcc>=$pkgver" 'python2' 'boost' "comgr>=$pkgver" 'rocminfo' 'hsa-ext-rocr')
+makedepends=('cmake' "hcc>=$pkgver" 'python' 'boost' "comgr>=$pkgver" 'rocminfo' 'hsa-ext-rocr')
source=("https://github.com/ROCmSoftwarePlatform/rocBLAS/archive/rocm-$_pkgver.tar.gz")
sha256sums=('aaa8f0479202bdbe94d2ec5655a76055656f743b0d36816501cb84a533084034')
@@ -30,8 +30,12 @@ build() {
-HIP_DIR=/opt/rocm/hip/lib/cmake/hip \
-hcc_DIR=/opt/rocm/hcc/lib/cmake/hcc \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
- -DBUILD_WITH_TENSILE=OFF \
"$srcdir/rocBLAS-rocm-$_pkgver"
+
+ # Fix for latest llvm
+ sed -i 's/Impl::inputOne(io, key, \*value)/Impl::inputOne(io, key.str(), \*value)/g' \
+ $srcdir/build/virtualenv/lib/python*/site-packages/Tensile/Source/lib/include/Tensile/llvm/YAML.hpp
+
make
}