summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2015-06-08 09:27:31 -0400
committerJameson Pugh2015-06-08 09:27:31 -0400
commit74897ab06355371655bdc11d7cd2a4e6b57d9dd1 (patch)
tree591feb1aba67fcfdb711ccebda56c064f2d218ad
downloadaur-74897ab06355371655bdc11d7cd2a4e6b57d9dd1.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD34
-rw-r--r--roccat-dkms.install22
3 files changed, 76 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..57f981143486
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = roccat-dkms
+ pkgdesc = Kernel modules for ROCCAT devices
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = http://roccat.sourceforge.net
+ install = roccat-dkms.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = dkms
+ optdepends = linux-headers: build the module against Arch kernel
+ optdepends = linux-lts-headers: build the module against LTS Arch kernel
+ optdepends = roccat-tools: graphical tools to adjust the mouse settings
+ provides = kmod-roccat
+ conflicts = kmod-roccat
+ source = http://downloads.sourceforge.net/project/roccat/linux/kmod-roccat/kmod-roccat-1.0.0.tar.bz2
+ sha256sums = 432c5100bdfbd19f54938129ff18331f70c12d3fd4f145ea5a1093a363ce9594
+
+pkgname = roccat-dkms
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fb9f7a6531d5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+# Contributor: Jameson Pugh <imntreal@gmail.com>
+
+pkgname=roccat-dkms
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Kernel modules for ROCCAT devices"
+arch=('i686' 'x86_64')
+url="http://roccat.sourceforge.net"
+license=('GPL')
+depends=('dkms')
+optdepends=('linux-headers: build the module against Arch kernel'
+ 'linux-lts-headers: build the module against LTS Arch kernel'
+ 'roccat-tools: graphical tools to adjust the mouse settings')
+conflicts=('kmod-roccat')
+provides=('kmod-roccat')
+source=("http://downloads.sourceforge.net/project/roccat/linux/kmod-roccat/kmod-roccat-$pkgver.tar.bz2")
+install=$pkgname.install
+sha256sums=('432c5100bdfbd19f54938129ff18331f70c12d3fd4f145ea5a1093a363ce9594')
+
+package() {
+ cd ${srcdir}/kmod-roccat-${pkgver}
+
+#2.6.39_and_up
+
+ install -dm755 "${pkgdir}/usr/lib/modprobe.d"
+ install -dm755 "${pkgdir}/usr/src/${pkgname}-${pkgver}-${pkgrel}"
+ cp -r ./* "${pkgdir}/usr/src/${pkgname}-${pkgver}-${pkgrel}/"
+ sed -i -e "s/@VERSION@/${pkgver}-${pkgrel}/" "${pkgdir}/usr/src/${pkgname}-${pkgver}-${pkgrel}/dkms.conf"
+
+ install -D override-roccat.conf $pkgdir/usr/lib/depmod.d/override-roccat.conf
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/roccat-dkms.install b/roccat-dkms.install
new file mode 100644
index 000000000000..6f5a3a4becd1
--- /dev/null
+++ b/roccat-dkms.install
@@ -0,0 +1,22 @@
+post_install() {
+ dkms install -m roccat-dkms -v $1
+ echo " Add roccat, roccat-common and your specific mouse driver to"
+ echo " /etc/modules-load.d/modules.conf if you want to load it on boot."
+}
+
+pre_upgrade() {
+ local curver=$2
+ # $2 is unset due to a bug. Query current version using pacman as fallback
+ [ -n "$curver" ] || curver=$(pacman -Qi roccat-dkms | awk '/^Version/{print $3}')
+ pre_remove $curver
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+pre_remove() {
+ dkms remove -m roccat-dkms -v $1 --all
+}
+
+# vim:set ts=2 sw=2 et: