summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Mueller2014-05-12 22:17:12 +0200
committerAaron Mueller2014-05-12 22:17:12 +0200
commit4866f6b6c1cfee61d04b430b5f7d331e6617132a (patch)
tree406a6d2b3ad0a85729f781ab3e14987d2a236ca3
parent9dc7c556ec3238b6ddc0932cc70ad956092c7af9 (diff)
downloadaur-4866f6b6c1cfee61d04b430b5f7d331e6617132a.tar.gz
Clean up the roccat-tools package and add a meta-package
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD55
2 files changed, 26 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf4162a70be0..53e0475a15f3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = roccat-tools
pkgdesc = Userland applications to configure and make extended use of ROCCAT devices
pkgver = 1.5.1
- pkgrel = 1
+ pkgrel = 2
url = http://roccat.sourceforge.net
arch = i686
arch = x86_64
@@ -19,6 +19,8 @@ pkgbase = roccat-tools
source = http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-1.5.1.tar.bz2
md5sums = ef1c776a0add38a90a83af4e1fd4bfe2
+pkgname = roccat-tools
+
pkgname = roccat-tools-common
pkgname = roccat-tools-arvo
diff --git a/PKGBUILD b/PKGBUILD
index de97a785eece..c119d2f07dda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,8 @@ pkgname=roccat-tools
# To trick the AUR package parser (on the website), we need to "cover" the pkgname
# list with the "true &&" hack. This way, the package will be displayed as
# "roccat-tools" on the website.
-true && pkgname=('roccat-tools-common'
+true && pkgname=('roccat-tools'
+ 'roccat-tools-common'
'roccat-tools-arvo'
'roccat-tools-isku'
'roccat-tools-iskufx'
@@ -24,10 +25,10 @@ true && pkgname=('roccat-tools-common'
'roccat-tools-savu')
pkgbase=roccat-tools
pkgver=1.5.1
-pkgrel=1
-pkgdesc="Userland applications to configure and make extended use of ROCCAT devices"
+pkgrel=2
+pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
arch=('i686' 'x86_64')
-url="http://roccat.sourceforge.net"
+url='http://roccat.sourceforge.net'
license=('GPL2')
depends=('libgaminggear' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'libusb' 'dbus-glib' 'udev' 'hicolor-icon-theme')
makedepends=('cmake')
@@ -43,10 +44,13 @@ build() {
make
}
+package_roccat-tools() {
+ /bin/true
+}
+
package_roccat-tools-common() {
- true && pkgdesc="ROCCAT tools common files"
+ true && pkgdesc='ROCCAT tools common files'
install=roccat-tools.install
- true && conflicts=('roccat-tools')
for i in icons sounds libroccat libroccathelper libroccatwidget roccateventhandler; do
cd $srcdir/$pkgbase-$pkgver/$i
@@ -55,9 +59,8 @@ install=roccat-tools.install
}
package_roccat-tools-arvo() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Arvo devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Arvo devices'
true && depends=('roccat-tools-common')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/arvo"
make DESTDIR="$pkgdir/" install
@@ -66,9 +69,8 @@ package_roccat-tools-arvo() {
}
package_roccat-tools-isku() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Isku devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Isku devices'
true && depends=('roccat-tools-common')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/isku"
make DESTDIR="$pkgdir/" install
@@ -77,9 +79,8 @@ package_roccat-tools-isku() {
}
package_roccat-tools-iskufx() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Isku FX devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Isku FX devices'
true && depends=('roccat-tools-common' 'roccat-tools-isku')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/iskufx"
make DESTDIR="$pkgdir/" install
@@ -88,9 +89,8 @@ package_roccat-tools-iskufx() {
}
package_roccat-tools-kone() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Kone devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone devices'
true && depends=('roccat-tools-common')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/kone"
make DESTDIR="$pkgdir/" install
@@ -99,9 +99,8 @@ package_roccat-tools-kone() {
}
package_roccat-tools-koneplus() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Kone[+] devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone[+] devices'
true && depends=('roccat-tools-common')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/koneplus"
make DESTDIR="$pkgdir/" install
@@ -110,9 +109,8 @@ package_roccat-tools-koneplus() {
}
package_roccat-tools-konepure() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Kone Pure devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone Pure devices'
true && depends=('roccat-tools-common' 'roccat-tools-konextd')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/konepure"
make DESTDIR="$pkgdir/" install
@@ -121,9 +119,8 @@ package_roccat-tools-konepure() {
}
package_roccat-tools-konepureoptical() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Kone Pure optical devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone Pure optical devices'
true && depends=('roccat-tools-common' 'roccat-tools-konepure')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/konepureoptical"
make DESTDIR="$pkgdir/" install
@@ -132,9 +129,8 @@ package_roccat-tools-konepureoptical() {
}
package_roccat-tools-konextd() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Kone XTD devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone XTD devices'
true && depends=('roccat-tools-common' 'roccat-tools-koneplus')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/konextd"
make DESTDIR="$pkgdir/" install
@@ -143,9 +139,8 @@ package_roccat-tools-konextd() {
}
package_roccat-tools-kovaplus() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Kova[+] devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kova[+] devices'
true && depends=('roccat-tools-common')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/kovaplus"
make DESTDIR="$pkgdir/" install
@@ -154,9 +149,8 @@ package_roccat-tools-kovaplus() {
}
package_roccat-tools-lua() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Lua devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Lua devices'
true && depends=('roccat-tools-common')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/lua"
make DESTDIR="$pkgdir/" install
@@ -165,9 +159,8 @@ package_roccat-tools-lua() {
}
package_roccat-tools-pyra() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Pyra devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Pyra devices'
true && depends=('roccat-tools-common')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/pyra"
make DESTDIR="$pkgdir/" install
@@ -176,9 +169,8 @@ package_roccat-tools-pyra() {
}
package_roccat-tools-ryos() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Ryos devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Ryos devices'
true && depends=('roccat-tools-common')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/ryos"
make DESTDIR="$pkgdir/" install
@@ -187,9 +179,8 @@ package_roccat-tools-ryos() {
}
package_roccat-tools-savu() {
- true && pkgdesc="Userland applications to configure and make extended use of ROCCAT Savu devices"
+ true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Savu devices'
true && depends=('roccat-tools-common')
- true && conflicts=('roccat-tools')
cd "$srcdir/$pkgbase-$pkgver/savu"
make DESTDIR="$pkgdir/" install