summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Mueller2014-06-10 00:16:14 +0200
committerAaron Mueller2014-06-10 00:16:14 +0200
commit56104ceaf90bda11acb935b3023557b9d6cadb64 (patch)
treecc28a556c7123bce71713d9b9e6daa44f537bc8c
parent7330b9402bfa5e83a9397c495bef83002972353d (diff)
downloadaur-56104ceaf90bda11acb935b3023557b9d6cadb64.tar.gz
Fix some issues with the roccat-tools basepackage/splittpackage
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD90
2 files changed, 75 insertions, 51 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd6dc4ba7e2f..51319add1ec4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = roccat-tools
pkgdesc = Userland applications to configure and make extended use of ROCCAT devices
pkgver = 1.6.0
- pkgrel = 2
+ pkgrel = 3
url = http://roccat.sourceforge.net
arch = i686
arch = x86_64
@@ -19,33 +19,63 @@ pkgbase = roccat-tools
source = http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-1.6.0.tar.bz2
md5sums = bfa32d3de9802e2970c13ae9eca85209
-pkgname = roccat-tools
-
pkgname = roccat-tools-common
+ pkgdesc = ROCCAT tools common files
+ install=roccat-tools.install
pkgname = roccat-tools-arvo
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Arvo devices
+ depends = roccat-tools-common
pkgname = roccat-tools-isku
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Isku devices
+ depends = roccat-tools-common
pkgname = roccat-tools-iskufx
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Isku FX devices
+ depends = roccat-tools-common
+ depends = roccat-tools-isku
pkgname = roccat-tools-kone
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Kone devices
+ depends = roccat-tools-common
pkgname = roccat-tools-koneplus
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Kone[+] devices
+ depends = roccat-tools-common
pkgname = roccat-tools-konepure
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Kone Pure devices
+ depends = roccat-tools-common
+ depends = roccat-tools-konextd
pkgname = roccat-tools-konepureoptical
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Kone Pure optical devices
+ depends = roccat-tools-common
+ depends = roccat-tools-konepure
pkgname = roccat-tools-konextd
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Kone XTD devices
+ depends = roccat-tools-common
+ depends = roccat-tools-koneplus
pkgname = roccat-tools-kovaplus
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Kova[+] devices
+ depends = roccat-tools-common
pkgname = roccat-tools-lua
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Lua devices
+ depends = roccat-tools-common
pkgname = roccat-tools-pyra
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Pyra devices
+ depends = roccat-tools-common
pkgname = roccat-tools-ryos
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Ryos devices
+ depends = roccat-tools-common
pkgname = roccat-tools-savu
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT Savu devices
+ depends = roccat-tools-common
diff --git a/PKGBUILD b/PKGBUILD
index 7d36c1ccfe2c..50a00267e741 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,29 +3,23 @@
# Contributor: Xpander <xpander0@gmail.com>
# Contributor: Stefan Achatz <erazor_de@users.soruceforge.net>
-pkgname=roccat-tools
-
-# To trick the AUR package parser (on the website), we need to "cover" the pkgname
-# list with the "true &&" hack. This way, the package will be displayed as
-# "roccat-tools" on the website.
-true && pkgname=('roccat-tools'
- 'roccat-tools-common'
- 'roccat-tools-arvo'
- 'roccat-tools-isku'
- 'roccat-tools-iskufx'
- 'roccat-tools-kone'
- 'roccat-tools-koneplus'
- 'roccat-tools-konepure'
- 'roccat-tools-konepureoptical'
- 'roccat-tools-konextd'
- 'roccat-tools-kovaplus'
- 'roccat-tools-lua'
- 'roccat-tools-pyra'
- 'roccat-tools-ryos'
- 'roccat-tools-savu')
+pkgname=('roccat-tools-common'
+ 'roccat-tools-arvo'
+ 'roccat-tools-isku'
+ 'roccat-tools-iskufx'
+ 'roccat-tools-kone'
+ 'roccat-tools-koneplus'
+ 'roccat-tools-konepure'
+ 'roccat-tools-konepureoptical'
+ 'roccat-tools-konextd'
+ 'roccat-tools-kovaplus'
+ 'roccat-tools-lua'
+ 'roccat-tools-pyra'
+ 'roccat-tools-ryos'
+ 'roccat-tools-savu')
pkgbase=roccat-tools
pkgver=1.6.0
-pkgrel=2
+pkgrel=3
pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
arch=('i686' 'x86_64')
url='http://roccat.sourceforge.net'
@@ -49,7 +43,7 @@ package_roccat-tools() {
}
package_roccat-tools-common() {
- true && pkgdesc='ROCCAT tools common files'
+ pkgdesc='ROCCAT tools common files'
install=roccat-tools.install
for i in icons sounds libroccat libroccathelper libroccatwidget roccateventhandler; do
@@ -59,8 +53,8 @@ install=roccat-tools.install
}
package_roccat-tools-arvo() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Arvo devices'
- true && depends=('roccat-tools-common')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Arvo devices'
+ depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/arvo"
make DESTDIR="$pkgdir/" install
@@ -69,8 +63,8 @@ package_roccat-tools-arvo() {
}
package_roccat-tools-isku() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Isku devices'
- true && depends=('roccat-tools-common')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Isku devices'
+ depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/isku"
make DESTDIR="$pkgdir/" install
@@ -79,8 +73,8 @@ package_roccat-tools-isku() {
}
package_roccat-tools-iskufx() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Isku FX devices'
- true && depends=('roccat-tools-common' 'roccat-tools-isku')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Isku FX devices'
+ depends=('roccat-tools-common' 'roccat-tools-isku')
cd "$srcdir/$pkgbase-$pkgver/iskufx"
make DESTDIR="$pkgdir/" install
@@ -89,8 +83,8 @@ package_roccat-tools-iskufx() {
}
package_roccat-tools-kone() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone devices'
- true && depends=('roccat-tools-common')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone devices'
+ depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/kone"
make DESTDIR="$pkgdir/" install
@@ -99,8 +93,8 @@ package_roccat-tools-kone() {
}
package_roccat-tools-koneplus() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone[+] devices'
- true && depends=('roccat-tools-common')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone[+] devices'
+ depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/koneplus"
make DESTDIR="$pkgdir/" install
@@ -109,8 +103,8 @@ package_roccat-tools-koneplus() {
}
package_roccat-tools-konepure() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone Pure devices'
- true && depends=('roccat-tools-common' 'roccat-tools-konextd')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone Pure devices'
+ depends=('roccat-tools-common' 'roccat-tools-konextd')
cd "$srcdir/$pkgbase-$pkgver/konepure"
make DESTDIR="$pkgdir/" install
@@ -119,8 +113,8 @@ package_roccat-tools-konepure() {
}
package_roccat-tools-konepureoptical() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone Pure optical devices'
- true && depends=('roccat-tools-common' 'roccat-tools-konepure')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone Pure optical devices'
+ depends=('roccat-tools-common' 'roccat-tools-konepure')
cd "$srcdir/$pkgbase-$pkgver/konepureoptical"
make DESTDIR="$pkgdir/" install
@@ -129,8 +123,8 @@ package_roccat-tools-konepureoptical() {
}
package_roccat-tools-konextd() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone XTD devices'
- true && depends=('roccat-tools-common' 'roccat-tools-koneplus')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Kone XTD devices'
+ depends=('roccat-tools-common' 'roccat-tools-koneplus')
cd "$srcdir/$pkgbase-$pkgver/konextd"
make DESTDIR="$pkgdir/" install
@@ -139,8 +133,8 @@ package_roccat-tools-konextd() {
}
package_roccat-tools-kovaplus() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Kova[+] devices'
- true && depends=('roccat-tools-common')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Kova[+] devices'
+ depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/kovaplus"
make DESTDIR="$pkgdir/" install
@@ -149,8 +143,8 @@ package_roccat-tools-kovaplus() {
}
package_roccat-tools-lua() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Lua devices'
- true && depends=('roccat-tools-common')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Lua devices'
+ depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/lua"
make DESTDIR="$pkgdir/" install
@@ -159,8 +153,8 @@ package_roccat-tools-lua() {
}
package_roccat-tools-pyra() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Pyra devices'
- true && depends=('roccat-tools-common')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Pyra devices'
+ depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/pyra"
make DESTDIR="$pkgdir/" install
@@ -169,8 +163,8 @@ package_roccat-tools-pyra() {
}
package_roccat-tools-ryos() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Ryos devices'
- true && depends=('roccat-tools-common')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Ryos devices'
+ depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/ryos"
make DESTDIR="$pkgdir/" install
@@ -179,8 +173,8 @@ package_roccat-tools-ryos() {
}
package_roccat-tools-savu() {
- true && pkgdesc='Userland applications to configure and make extended use of ROCCAT Savu devices'
- true && depends=('roccat-tools-common')
+ pkgdesc='Userland applications to configure and make extended use of ROCCAT Savu devices'
+ depends=('roccat-tools-common')
cd "$srcdir/$pkgbase-$pkgver/savu"
make DESTDIR="$pkgdir/" install