summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2015-08-17 10:49:18 -0400
committerJameson Pugh2015-08-17 10:49:18 -0400
commit53494709145e4610697a546e61c6e13a859a462b (patch)
treee9d2c0288b73ca4d9a7cbad9c85bae0d77c3f1a3
parentc33cf1b07e5448370cb8e6af3d48b2678633dda3 (diff)
downloadaur-53494709145e4610697a546e61c6e13a859a462b.tar.gz
version 3.5.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--ryosmk-dbus-bindings-v320.patch38
3 files changed, 10 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 845dc10bc8f6..d65fd5306390 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = roccat-tools-full
pkgdesc = Userland applications to configure and make extended use of ROCCAT devices
- pkgver = 3.2.0
+ pkgver = 3.5.0
pkgrel = 1
url = http://roccat.sourceforge.net
install = roccat-tools.install
@@ -8,7 +8,7 @@ pkgbase = roccat-tools-full
arch = x86_64
license = GPL2
makedepends = cmake
- depends = libgaminggear>=0.7.0
+ depends = libgaminggear>=0.10.1
depends = libcanberra
depends = gtk2
depends = libnotify>=0.7.0
@@ -19,9 +19,9 @@ pkgbase = roccat-tools-full
optdepends = roccat-dkms: Adds support for the old kone device with dynamic rebuild.
conflicts = roccat-tools-common
replaces = roccat-tools-common
- source = http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-3.2.0.tar.bz2
- source = ryosmk-dbus-bindings-v320.patch
- sha1sums = f75c1068f773242b343df663d51707e6b0511afb
+ source = http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-3.5.0.tar.bz2
+ source =
+ sha1sums = 2eb75f596a282a388714a3449ee45836f42c76b6
sha1sums = 56cde9cd4f1c296f5316b0d47b7d917c6819900f
pkgname = roccat-tools-full
diff --git a/PKGBUILD b/PKGBUILD
index 59ca85a2df53..25cc07229d6f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,28 +6,28 @@
pkgname=('roccat-tools-full')
_pkgbase=roccat-tools
-pkgver=3.2.0
+pkgver=3.5.0
pkgrel=1
pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
arch=('i686' 'x86_64')
url='http://roccat.sourceforge.net'
license=('GPL2')
-depends=('libgaminggear>=0.7.0' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'dbus-glib' 'udev' 'hicolor-icon-theme')
+depends=('libgaminggear>=0.10.1' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'dbus-glib' 'udev' 'hicolor-icon-theme')
makedepends=('cmake')
optdepends=('kmod-roccat: Adds support for the old kone device.'
'roccat-dkms: Adds support for the old kone device with dynamic rebuild.')
conflicts=('roccat-tools-common')
replaces=('roccat-tools-common')
source=("http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-$pkgver.tar.bz2"
- 'ryosmk-dbus-bindings-v320.patch')
+ '')
install=roccat-tools.install
-sha1sums=('f75c1068f773242b343df663d51707e6b0511afb'
+sha1sums=('2eb75f596a282a388714a3449ee45836f42c76b6'
'56cde9cd4f1c296f5316b0d47b7d917c6819900f')
build() {
cd "$srcdir/$_pkgbase-$pkgver"
- patch -p1 -i ../ryosmk-dbus-bindings-v320.patch
+ patch -p1 -i ../udev-compilation-error-fix.patch
cmake . -DCMAKE_INSTALL_PREFIX=/usr -DUDEVDIR=/usr/lib/udev/rules.d -DWITHOUT_PYTHON=TRUE
make
}
diff --git a/ryosmk-dbus-bindings-v320.patch b/ryosmk-dbus-bindings-v320.patch
deleted file mode 100644
index 8f4c27197c0f..000000000000
--- a/ryosmk-dbus-bindings-v320.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-diff --git a/libroccat/CMakeLists.txt b/libroccat/CMakeLists.txt
-index ead603c..bf61d05 100644
---- a/libroccat/CMakeLists.txt
-+++ b/libroccat/CMakeLists.txt
-@@ -46,6 +46,7 @@ SET(SOURCES
-
- SET(LIBRARIES
- libroccathelper
-+ ${DBUS_LIBRARIES}
- ${GAMINGGEAR0_LIBRARY}
- )
-
-diff --git a/ryosmk/libroccatryosmk/CMakeLists.txt b/ryosmk/libroccatryosmk/CMakeLists.txt
-index 0e4243a..69c56e9 100644
---- a/ryosmk/libroccatryosmk/CMakeLists.txt
-+++ b/ryosmk/libroccatryosmk/CMakeLists.txt
-@@ -33,7 +33,7 @@ ADD_LIBRARY(libroccatryosmk SHARED
-
- ADD_DEPENDENCIES(libroccatryosmk
- generated_headers
-- ryos_dbus_bindings
-+ ryosmk_dbus_bindings
- )
-
- TARGET_LINK_LIBRARIES(libroccatryosmk
-diff --git a/ryosmk/libryosmkeventhandler/CMakeLists.txt b/ryosmk/libryosmkeventhandler/CMakeLists.txt
-index ab26de8..ad93376 100644
---- a/ryosmk/libryosmkeventhandler/CMakeLists.txt
-+++ b/ryosmk/libryosmkeventhandler/CMakeLists.txt
-@@ -22,7 +22,7 @@ ADD_LIBRARY(libryosmkeventhandler SHARED ${SOURCES})
-
- ADD_DEPENDENCIES(libryosmkeventhandler
- generated_headers
-- ryos_dbus_bindings
-+ ryosmk_dbus_bindings
- )
-
- SET_TARGET_PROPERTIES(libryosmkeventhandler