summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJameson Pugh2015-06-08 09:27:31 -0400
committerJameson Pugh2015-06-08 09:27:31 -0400
commitc33cf1b07e5448370cb8e6af3d48b2678633dda3 (patch)
tree2b7adeecd178b352415bea3e575e80f4e68c929b
downloadaur-c33cf1b07e5448370cb8e6af3d48b2678633dda3.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD127
-rwxr-xr-xroccat-tools.install29
-rw-r--r--ryosmk-dbus-bindings-v320.patch38
4 files changed, 222 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..845dc10bc8f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = roccat-tools-full
+ pkgdesc = Userland applications to configure and make extended use of ROCCAT devices
+ pkgver = 3.2.0
+ pkgrel = 1
+ url = http://roccat.sourceforge.net
+ install = roccat-tools.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ depends = libgaminggear>=0.7.0
+ depends = libcanberra
+ depends = gtk2
+ depends = libnotify>=0.7.0
+ depends = dbus-glib
+ depends = udev
+ depends = hicolor-icon-theme
+ optdepends = kmod-roccat: Adds support for the old kone device.
+ optdepends = roccat-dkms: Adds support for the old kone device with dynamic rebuild.
+ conflicts = roccat-tools-common
+ replaces = roccat-tools-common
+ source = http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-3.2.0.tar.bz2
+ source = ryosmk-dbus-bindings-v320.patch
+ sha1sums = f75c1068f773242b343df663d51707e6b0511afb
+ sha1sums = 56cde9cd4f1c296f5316b0d47b7d917c6819900f
+
+pkgname = roccat-tools-full
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59ca85a2df53
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,127 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+# Contributor: Aaron Fischer <mail@aaron-fischer.net>
+# Contributor: Nuno Araujo <nuno.araujo@russo79.com>
+# Contributor: Xpander <xpander0@gmail.com>
+# Contributor: Stefan Achatz <erazor_de@users.soruceforge.net>
+
+pkgname=('roccat-tools-full')
+_pkgbase=roccat-tools
+pkgver=3.2.0
+pkgrel=1
+pkgdesc='Userland applications to configure and make extended use of ROCCAT devices'
+arch=('i686' 'x86_64')
+url='http://roccat.sourceforge.net'
+license=('GPL2')
+depends=('libgaminggear>=0.7.0' 'libcanberra' 'gtk2' 'libnotify>=0.7.0' 'dbus-glib' 'udev' 'hicolor-icon-theme')
+makedepends=('cmake')
+optdepends=('kmod-roccat: Adds support for the old kone device.'
+ 'roccat-dkms: Adds support for the old kone device with dynamic rebuild.')
+conflicts=('roccat-tools-common')
+replaces=('roccat-tools-common')
+source=("http://downloads.sourceforge.net/project/roccat/roccat-tools/roccat-tools-$pkgver.tar.bz2"
+ 'ryosmk-dbus-bindings-v320.patch')
+install=roccat-tools.install
+sha1sums=('f75c1068f773242b343df663d51707e6b0511afb'
+ '56cde9cd4f1c296f5316b0d47b7d917c6819900f')
+
+build() {
+ cd "$srcdir/$_pkgbase-$pkgver"
+
+ patch -p1 -i ../ryosmk-dbus-bindings-v320.patch
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DUDEVDIR=/usr/lib/udev/rules.d -DWITHOUT_PYTHON=TRUE
+ make
+}
+
+package() {
+ for i in icons sounds libroccat libroccathelper libroccatwidget roccateventhandler; do
+ cd $srcdir/$_pkgbase-$pkgver/$i
+ make DESTDIR="$pkgdir/" install
+ done
+
+ cd "$srcdir/$_pkgbase-$pkgver/arvo"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-arvo.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-arvo.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/isku"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-isku.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-isku.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/iskufx"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-iskufx.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-iskufx.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/kone"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-kone.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-kone.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/koneplus"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-koneplus.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-koneplus.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/konepure"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-konepure.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-konepure.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/konepureoptical"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-konepureoptical.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-konepureoptical.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/konepuremilitary"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-savu.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-konepuremilitary.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/konextd"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-konextd.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-konextd.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/konextdoptical"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-savu.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-konextdoptical.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/kovaplus"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-kovaplus.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-kovaplus.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/lua"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-lua.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-lua.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/pyra"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-pyra.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-pyra.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/ryosmk"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-ryosmk.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-ryosmk.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/ryostkl"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-ryostkl.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-ryostkl.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/savu"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-savu.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-savu.rules
+
+ cd "$srcdir/$_pkgbase-$pkgver/tyon"
+ make DESTDIR="$pkgdir/" install
+ cd "$srcdir/$_pkgbase-$pkgver"
+ install -Dm644 udev/90-roccat-tyon.rules $pkgdir/usr/lib/udev/rules.d/90-roccat-tyon.rules
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/roccat-tools.install b/roccat-tools.install
new file mode 100755
index 000000000000..5b15313315e5
--- /dev/null
+++ b/roccat-tools.install
@@ -0,0 +1,29 @@
+post_install() {
+ ldconfig
+ touch --no-create /usr/share/icons/hicolor
+
+ groupadd --force roccat
+
+ mkdir --parents /var/lib/roccat
+ chown root:roccat /var/lib/roccat
+ chmod 2770 /var/lib/roccat
+
+ udevadm control --reload-rules
+}
+
+post_upgrade() {
+ ldconfig
+ touch --no-create /usr/share/icons/hicolor
+ udevadm control --reload-rules
+}
+
+post_remove() {
+ ldconfig
+ udevadm control --reload-rules
+
+ # If there are some configuration files in this dir, we get an error, which
+ # is good because we don't want to remove the user configs.
+ rm -r /var/lib/roccat
+
+ groupdel roccat
+}
diff --git a/ryosmk-dbus-bindings-v320.patch b/ryosmk-dbus-bindings-v320.patch
new file mode 100644
index 000000000000..8f4c27197c0f
--- /dev/null
+++ b/ryosmk-dbus-bindings-v320.patch
@@ -0,0 +1,38 @@
+diff --git a/libroccat/CMakeLists.txt b/libroccat/CMakeLists.txt
+index ead603c..bf61d05 100644
+--- a/libroccat/CMakeLists.txt
++++ b/libroccat/CMakeLists.txt
+@@ -46,6 +46,7 @@ SET(SOURCES
+
+ SET(LIBRARIES
+ libroccathelper
++ ${DBUS_LIBRARIES}
+ ${GAMINGGEAR0_LIBRARY}
+ )
+
+diff --git a/ryosmk/libroccatryosmk/CMakeLists.txt b/ryosmk/libroccatryosmk/CMakeLists.txt
+index 0e4243a..69c56e9 100644
+--- a/ryosmk/libroccatryosmk/CMakeLists.txt
++++ b/ryosmk/libroccatryosmk/CMakeLists.txt
+@@ -33,7 +33,7 @@ ADD_LIBRARY(libroccatryosmk SHARED
+
+ ADD_DEPENDENCIES(libroccatryosmk
+ generated_headers
+- ryos_dbus_bindings
++ ryosmk_dbus_bindings
+ )
+
+ TARGET_LINK_LIBRARIES(libroccatryosmk
+diff --git a/ryosmk/libryosmkeventhandler/CMakeLists.txt b/ryosmk/libryosmkeventhandler/CMakeLists.txt
+index ab26de8..ad93376 100644
+--- a/ryosmk/libryosmkeventhandler/CMakeLists.txt
++++ b/ryosmk/libryosmkeventhandler/CMakeLists.txt
+@@ -22,7 +22,7 @@ ADD_LIBRARY(libryosmkeventhandler SHARED ${SOURCES})
+
+ ADD_DEPENDENCIES(libryosmkeventhandler
+ generated_headers
+- ryos_dbus_bindings
++ ryosmk_dbus_bindings
+ )
+
+ SET_TARGET_PROPERTIES(libryosmkeventhandler