summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnthony Wang2022-03-18 04:02:55 -0500
committerGitHub2022-03-18 10:02:55 +0100
commit06840cb76f649d2546e170a2bbbcf850dba6ef03 (patch)
treeacd215119c82253c4c0b56bef924f0c24c60fbe4
parent397e1e23589deaf55ea952cbc15c74a71e915fa9 (diff)
downloadaur-06840cb76f649d2546e170a2bbbcf850dba6ef03.tar.gz
Use cmake -DAMDGPU_TARGETS=${AMDGPU_TARGETS} to specify GPU targets (#650)
hip-runtime-amd https://github.com/ROCm-Developer-Tools/hipamd/blob/develop/hip-config.cmake.in#L165 hipcub https://github.com/ROCmSoftwarePlatform/hipCUB/blob/develop/CMakeLists.txt#L62 hipfft https://github.com/ROCmSoftwarePlatform/hipfft/blob/develop/CMakeLists.txt#L108 rccl https://github.com/ROCmSoftwarePlatform/rccl/blob/develop/CMakeLists.txt#L45 rocalution https://github.com/ROCmSoftwarePlatform/rocalution/blob/develop/CMakeLists.txt#L84 rocblas https://github.com/ROCmSoftwarePlatform/rocblas/blob/develop/CMakeLists.txt#L91 rocfft https://github.com/ROCmSoftwarePlatform/rocfft/blob/develop/CMakeLists.txt#L142 rocrand https://github.com/ROCmSoftwarePlatform/rocrand/blob/develop/CMakeLists.txt#L79 rocsolver https://github.com/ROCmSoftwarePlatform/rocsolver/blob/develop/CMakeLists.txt#L128 rocsparse https://github.com/ROCmSoftwarePlatform/rocsparse/blob/develop/CMakeLists.txt#L158 rocthrust https://github.com/ROCmSoftwarePlatform/rocthrust/blob/develop/CMakeLists.txt#L68
-rw-r--r--PKGBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4bedf59d62f8..256fd687f1b5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,8 @@ build() {
cmake -B build \
-S "$_dirname" \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -DCMAKE_CXX_COMPILER=hipcc
+ -DCMAKE_CXX_COMPILER=hipcc \
+ -DAMDGPU_TARGETS=${AMDGPU_TARGETS}
make -C build
}