summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2022-04-09 17:37:19 +0200
committerTorsten Keßler2022-04-09 17:37:19 +0200
commit3fef1a02d0f284c5b23c3bb8ca314e9061f0bdd5 (patch)
tree4aa449a9d528f167359bf0630944d03f4697dc22
parent71cb07ad6be787d55133a443f174412062e3f194 (diff)
downloadaur-3fef1a02d0f284c5b23c3bb8ca314e9061f0bdd5.tar.gz
upgpkg: rocfft 5.1.1-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9f48350a41a8..a27feb361d9f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = rocfft
pkgdesc = Next generation FFT implementation for ROCm
- pkgver = 5.1.0
+ pkgver = 5.1.1
pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocfft
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = rocfft
makedepends = cmake
depends = hip
options = !lto
- source = rocfft-5.1.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocFFT/archive/rocm-5.1.0.tar.gz
- sha256sums = dc11c9061753ae43a9d5db9c4674aa113a8adaf50818b2701cbb940894147f68
+ source = rocfft-5.1.1.tar.gz::https://github.com/ROCmSoftwarePlatform/rocFFT/archive/rocm-5.1.1.tar.gz
+ sha256sums = 1006c869bcf2886fc51ca69946771083184e3664aadb51a706c34975c2782f8a
pkgname = rocfft
diff --git a/PKGBUILD b/PKGBUILD
index 94c3b37c936f..80df4b2e6a6a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakub Okoński <jakub@okonski.org>
# Contributor: Markus Näther <naetherm@cs.uni-freiburg.de>
pkgname=rocfft
-pkgver=5.1.0
+pkgver=5.1.1
pkgrel=1
pkgdesc='Next generation FFT implementation for ROCm'
arch=('x86_64')
@@ -12,19 +12,23 @@ depends=('hip')
makedepends=('cmake')
_git='https://github.com/ROCmSoftwarePlatform/rocFFT'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('dc11c9061753ae43a9d5db9c4674aa113a8adaf50818b2701cbb940894147f68')
+sha256sums=('1006c869bcf2886fc51ca69946771083184e3664aadb51a706c34975c2782f8a')
options=(!lto)
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
+ local cmake_args=(-DCMAKE_INSTALL_PREFIX=/opt/rocm
+ -DCMAKE_CXX_COMPILER=hipcc)
+ if [[ -n "$AMDGPU_TARGETS" ]]; then
+ cmake_args+=(-DAMDGPU_TARGETS="$AMDGPU_TARGETS")
+ fi
+
# -fcf-protection is not supported by HIP, see
# https://github.com/ROCm-Developer-Tools/HIP/blob/develop/docs/markdown/clang_options.md
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -B build \
-S "$_dirname" \
- -DCMAKE_INSTALL_PREFIX=/opt/rocm \
- -DCMAKE_CXX_COMPILER=hipcc \
- -DAMDGPU_TARGETS=${AMDGPU_TARGETS:-gfx803;gfx900:xnack-;gfx906:xnack-;gfx908:xnack-;gfx90a:xnack-;gfx90a:xnack+;gfx1030}
+ "${cmake_args[@]}"
make -C build
}