summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTorsten Keßler2021-08-08 13:46:15 +0200
committerTorsten Keßler2021-08-08 13:46:15 +0200
commit5f7e671ceccf794cf47c7091e88a9d2a9da57513 (patch)
tree2c20b0f0e7376bbc8fde8566a13c0f427655e0da
parentdc331605f027e7af4f80f1ec9cdf6bbcfa97563f (diff)
downloadaur-5f7e671ceccf794cf47c7091e88a9d2a9da57513.tar.gz
upgpkg: rocfft 4.3.0-1
upstream release
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eec7b09eda6..864d4b09a7a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = rocfft
pkgdesc = Next generation FFT implementation for ROCm
- pkgver = 4.2.0
+ pkgver = 4.3.0
pkgrel = 1
url = https://rocmdocs.amd.com/en/latest/ROCm_Libraries/ROCm_Libraries.html#rocfft
arch = x86_64
license = MIT
makedepends = cmake
depends = hip-rocclr
- source = rocfft-4.2.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocFFT/archive/rocm-4.2.0.tar.gz
- sha256sums = db29c9067f0cfa98bddd3574f6aa7200cfc790cc6da352d19e4696c3f3982163
+ source = rocfft-4.3.0.tar.gz::https://github.com/ROCmSoftwarePlatform/rocFFT/archive/rocm-4.3.0.tar.gz
+ sha256sums = cb5b8f62330bc61b17a3a2fd1500068ee05d48cb51797901dd259dbc84610478
pkgname = rocfft
diff --git a/PKGBUILD b/PKGBUILD
index ee35766440d8..a509a9dd29fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Jakub Okoński <jakub@okonski.org>
# Contributor: Markus Näther <naetherm@cs.uni-freiburg.de>
pkgname=rocfft
-pkgver=4.2.0
+pkgver=4.3.0
pkgrel=1
pkgdesc='Next generation FFT implementation for ROCm'
arch=('x86_64')
@@ -12,15 +12,19 @@ depends=('hip-rocclr')
makedepends=('cmake')
_git='https://github.com/ROCmSoftwarePlatform/rocFFT'
source=("$pkgname-$pkgver.tar.gz::$_git/archive/rocm-$pkgver.tar.gz")
-sha256sums=('db29c9067f0cfa98bddd3574f6aa7200cfc790cc6da352d19e4696c3f3982163')
+sha256sums=('cb5b8f62330bc61b17a3a2fd1500068ee05d48cb51797901dd259dbc84610478')
_dirname="$(basename "$_git")-$(basename "${source[0]}" ".tar.gz")"
build() {
# -fcf-protection is not supported by HIP, see
- # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.2.x/docs/markdown/clang_options.md
+ # https://github.com/ROCm-Developer-Tools/HIP/blob/rocm-4.3.x/docs/markdown/clang_options.md
+
+ # With version 3.21, HIP support was added to CMake that breaks the current scripts, see
+ # https://github.com/ROCmSoftwarePlatform/rocRAND/issues/198#issuecomment-893573440
CXX=/opt/rocm/bin/hipcc \
CXXFLAGS="${CXXFLAGS} -fcf-protection=none" \
cmake -Wno-dev -S "$_dirname" \
+ -D__skip_rocmclang=ON \
-DCMAKE_INSTALL_PREFIX=/opt/rocm \
-Damd_comgr_DIR=/opt/rocm/lib/cmake/amd_comgr \
-DBUILD_CLIENTS_RIDER=OFF \