summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsum012018-01-26 01:05:13 -0500
committersum012018-01-26 01:05:13 -0500
commit0622472e516109cfd1bbe02d6dbc8449bf9072de (patch)
tree4c9bcdcaab25a176dfdbe41442537290563cf623
parent9ff438a2be2eec4a3eac2b1bee0d3ea427b530f0 (diff)
downloadaur-0622472e516109cfd1bbe02d6dbc8449bf9072de.tar.gz
v2.10.2 and remove check
I removed check since it seems to cause problems for people. More than it's worth anyways.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 03f41ce583ce..b748a676f3ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,11 @@
pkgbase = rocketchat-desktop
pkgdesc = Rocket.Chat Native Cross-Platform Desktop Application via Electron.
- pkgver = 2.10.1
+ pkgver = 2.10.2
pkgrel = 1
url = https://github.com/RocketChat/Rocket.Chat.Electron
arch = i686
arch = x86_64
license = MIT
- checkdepends = electron
makedepends = sed
makedepends = yarn
makedepends = gulp
@@ -18,8 +17,8 @@ pkgbase = rocketchat-desktop
depends = gtk2
depends = libxtst
conflicts = rocketchat-client-bin
- source = https://github.com/RocketChat/Rocket.Chat.Electron/archive/2.10.1.tar.gz
- sha512sums = 3b3f98749dcc052618e738f225b70d2495bec83cad6251f49983cfe30a3277c5172e8db9c2343439d9571facafd6282bcf534fc57007a08234d3e8d9aac7dc3f
+ source = https://github.com/RocketChat/Rocket.Chat.Electron/archive/2.10.2.tar.gz
+ sha512sums = 4641f280213f881f158a9d136fd4efb80050b26fd01536d68c6ef5eeeff7342aaa488821574ac40f0e682a86d4f1065a35fbbcec571125e5aef59987edcda1ab
pkgname = rocketchat-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 7db63fdb5e3d..a25003185992 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: sum01 <sum01@protonmail.com>
pkgname=rocketchat-desktop
-pkgver=2.10.1
+pkgver=2.10.2
_srcname="Rocket.Chat.Electron-$pkgver"
pkgrel=1
pkgdesc='Rocket.Chat Native Cross-Platform Desktop Application via Electron.'
@@ -9,10 +9,9 @@ url="https://github.com/RocketChat/Rocket.Chat.Electron"
license=('MIT')
depends=('libxss' 'gconf' 'nss' 'alsa-lib' 'gtk2' 'libxtst')
makedepends=('sed' 'yarn' 'gulp' 'python2')
-checkdepends=('electron')
conflicts=('rocketchat-client-bin')
source=("https://github.com/RocketChat/Rocket.Chat.Electron/archive/$pkgver.tar.gz")
-sha512sums=('3b3f98749dcc052618e738f225b70d2495bec83cad6251f49983cfe30a3277c5172e8db9c2343439d9571facafd6282bcf534fc57007a08234d3e8d9aac7dc3f')
+sha512sums=('4641f280213f881f158a9d136fd4efb80050b26fd01536d68c6ef5eeeff7342aaa488821574ac40f0e682a86d4f1065a35fbbcec571125e5aef59987edcda1ab')
prepare() {
sed -i 's/"deb",/"dir"/' "$srcdir/$_srcname/package.json"
sed -i '/"rpm"/d' "$srcdir/$_srcname/package.json"
@@ -23,11 +22,6 @@ build() {
yarn install --non-interactive --pure-lockfile --cache-folder "$srcdir/yarn-cache"
yarn release
}
-check() {
- cd "$srcdir/$_srcname"
- yarn check --integrity
- yarn test
-}
package() {
install -Dm644 "$srcdir/$_srcname/snap/gui/icon.png" "$pkgdir/usr/share/icons/hicolor/512x512/apps/$pkgname.png"
install -Dm644 "$srcdir/$_srcname/snap/gui/$pkgname.desktop" "$pkgdir/usr/share/applications/$pkgname/$pkgname.desktop"