summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorml2020-10-02 19:37:09 +0200
committerml2020-10-02 21:56:54 +0200
commitf90ff11d9245bb2bb9e649bba5231fc9df2e30b6 (patch)
tree34834de998828a7322d02e078f8a743b5f9f7f1d
parent1dcf8ebbfdb707f69a8c73e66bc5a839252ab422 (diff)
downloadaur-f90ff11d9245bb2bb9e649bba5231fc9df2e30b6.tar.gz
updpkg: rocketchat-desktop 3.0.1-1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD19
-rw-r--r--use-system-dictionaries.patch16
3 files changed, 12 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f8b242543159..c3abcfd9a97c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = rocketchat-desktop
pkgdesc = Rocket.Chat Native Cross-Platform Desktop Application via Electron.
- pkgver = 2.17.11
- pkgrel = 3
+ pkgver = 3.0.1
+ pkgrel = 1
url = https://github.com/RocketChat/Rocket.Chat.Electron
arch = i686
arch = x86_64
@@ -13,14 +13,12 @@ pkgbase = rocketchat-desktop
depends = electron
optdepends = hunspell-en_US: spell checking
conflicts = rocketchat-client-bin
- source = https://github.com/RocketChat/Rocket.Chat.Electron/archive/2.17.11/rocketchat-desktop-2.17.11.tar.gz
+ source = https://github.com/RocketChat/Rocket.Chat.Electron/archive/3.0.1/rocketchat-desktop-3.0.1.tar.gz
source = rocketchat-desktop
source = rocketchat-desktop.desktop
- source = use-system-dictionaries.patch
- sha256sums = 2f13cc5d62b2246db8715809c4278748a770e5975f1a439a5d922ef7af4e26b7
+ sha256sums = 6586b4745f2e2262f93eefce3e6001c0bb200e7eed243afeb8a37e6ad82bd1b5
sha256sums = 18fab390ffce4f89a17d5d71a7e78fea9afa9f9d2bcdafecb4f310d4f804996f
sha256sums = 31fae4f98a61a774f84030fd43d2ef92c7633740dc5aa55967a21d0e29ea621a
- sha256sums = 9a18a4db55c49c8c71c84e331d519dc16509c38566f5c1602224dc4a3ca73a3e
pkgname = rocketchat-desktop
diff --git a/PKGBUILD b/PKGBUILD
index cc810349f048..bda9d7ca12e9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
-# Maintainer: Matthias Lisin <ml@visu.li>
+# Maintainer: ml <>
# Contributor: sum01 <sum01@protonmail.com>
pkgname=rocketchat-desktop
-pkgver=2.17.11
+pkgver=3.0.1
_pkgname="Rocket.Chat.Electron-${pkgver}"
-pkgrel=3
+pkgrel=1
pkgdesc='Rocket.Chat Native Cross-Platform Desktop Application via Electron.'
arch=('i686' 'x86_64')
url='https://github.com/RocketChat/Rocket.Chat.Electron'
@@ -14,24 +14,21 @@ optdepends=('hunspell-en_US: spell checking')
conflicts=('rocketchat-client-bin')
source=("${url}/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz"
rocketchat-desktop
- rocketchat-desktop.desktop
- use-system-dictionaries.patch)
-sha256sums=('2f13cc5d62b2246db8715809c4278748a770e5975f1a439a5d922ef7af4e26b7'
+ rocketchat-desktop.desktop)
+sha256sums=('6586b4745f2e2262f93eefce3e6001c0bb200e7eed243afeb8a37e6ad82bd1b5'
'18fab390ffce4f89a17d5d71a7e78fea9afa9f9d2bcdafecb4f310d4f804996f'
- '31fae4f98a61a774f84030fd43d2ef92c7633740dc5aa55967a21d0e29ea621a'
- '9a18a4db55c49c8c71c84e331d519dc16509c38566f5c1602224dc4a3ca73a3e')
+ '31fae4f98a61a774f84030fd43d2ef92c7633740dc5aa55967a21d0e29ea621a')
prepare() {
cd "$_pkgname"
- patch -Np1 <../use-system-dictionaries.patch
- yarn upgrade electron@"$(</usr/lib/electron/version)" @babel/core@7.8.7 @babel/preset-env@7.8.7 --non-interactive
+ yarn upgrade electron@"$(</usr/lib/electron/version)"
}
build() {
cd "$_pkgname"
local i686=ia32 x86_64=x64
export NODE_ENV=production
- yarn gulp build
+ yarn build
yarn run electron-builder --linux --"${!CARCH}" --dir \
-c.electronDist=/usr/lib/electron \
-c.electronVersion="$(</usr/lib/electron/version)"
diff --git a/use-system-dictionaries.patch b/use-system-dictionaries.patch
deleted file mode 100644
index f6618556d14b..000000000000
--- a/use-system-dictionaries.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -ura package.orig/src/scripts/spellChecking.js package.new/src/scripts/spellChecking.js
---- package.orig/src/scripts/spellChecking.js 2020-02-11 13:55:00.000000000 +0100
-+++ package.new/src/scripts/spellChecking.js 2020-02-11 15:52:41.031198167 +0100
-@@ -140,11 +140,7 @@
-
- await provider.initialize();
-
-- const appDirectoriesPath = path.join(
-- remote.app.getAppPath(),
-- remote.app.getAppPath().endsWith('app.asar') ? '..' : '.',
-- 'dictionaries',
-- );
-+ const appDirectoriesPath = '/usr/share/hunspell';
-
- const appDictionaries = await getPairsOfDictionaryFiles(appDirectoriesPath);
-