summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAzat Khuzhin2017-08-20 23:54:36 +0300
committerAzat Khuzhin2017-08-21 00:00:18 +0300
commit65f53db0912e45bd751fd24907ff6c82a51aec87 (patch)
treec6fde90851743edb680e603b4ac46846643eba24
downloadaur-65f53db0912e45bd751fd24907ff6c82a51aec87.tar.gz
Initial commit
Based on "rocksdb" from aur, but with DEBUG_LEVEL=0
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD49
3 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dd15a4ed07c1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = rocksdb-release
+ pkgdesc = Embedded key-value store for fast storage
+ pkgver = 5.7.2
+ pkgrel = 1
+ url = http://rocksdb.org
+ arch = i686
+ arch = x86_64
+ license = Apache
+ license = leveldb
+ checkdepends = python2
+ makedepends = gcc
+ makedepends = make
+ depends = bzip2
+ depends = gcc-libs
+ depends = lz4
+ depends = snappy
+ depends = zlib
+ provides = rocksdb
+ conflicts = rocksdb
+ source = https://github.com/facebook/rocksdb/archive/v5.7.2.zip
+ sha256sums = b30bcc74047068e80f3fff685d1a11d13bdd4c55fde2930978f103cbfe9358cd
+
+pkgname = rocksdb-release
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..005561cb4477
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!PKGBUILD
+!.SRCINFO
+!.git*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf76cc0ee29f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+pkgname=rocksdb-release
+pkgver=5.7.2
+pkgrel=1
+pkgdesc='Embedded key-value store for fast storage'
+arch=(i686 x86_64)
+url='http://rocksdb.org'
+license=(Apache leveldb)
+depends=(
+ 'bzip2'
+ 'gcc-libs'
+ 'lz4'
+ 'snappy'
+ 'zlib'
+ )
+makedepends=('gcc' 'make')
+checkdepends=(python2)
+source=(https://github.com/facebook/rocksdb/archive/v$pkgver.zip)
+sha256sums=('b30bcc74047068e80f3fff685d1a11d13bdd4c55fde2930978f103cbfe9358cd')
+provides=(rocksdb)
+conflicts=(rocksdb)
+
+prepare() {
+ cd rocksdb-$pkgver
+ sed -e 's/\bpython\b/python2/' -i Makefile
+ if [ "$CARCH" == "armv6h" ]; then
+ sed -e 's/-momit-leaf-frame-pointer//' -i Makefile
+ fi
+}
+
+build() {
+ cd rocksdb-$pkgver
+ make clean
+ DEBUG_LEVEL=0 make shared_lib sst_dump -j4
+}
+
+#check() {
+# cd rocksdb-rocksdb-$pkgver
+# make check
+#}
+
+package() {
+ cd rocksdb-$pkgver
+ install -d "$pkgdir"/usr/include
+ cp -r include/rocksdb "$pkgdir"/usr/include
+ install -m755 -D sst_dump "$pkgdir"/usr/bin/sst_dump
+ install -m755 -D librocksdb.so "$pkgdir"/usr/lib/librocksdb.so
+ install -D -m644 LICENSE.Apache "$pkgdir/usr/share/licenses/$pkgname/LICENSE.Apache"
+ install -D -m644 LICENSE.leveldb "$pkgdir/usr/share/licenses/$pkgname/LICENSE.leveldb"
+}